Command to enable/disable Thing doesnt work anymore

2022-04-10 17:32:43.272 [WARN ] [shd.server.session.ServerSessionImpl] - exceptionCaught(ServerSessionImpl[null@/])[state=Opened] IOException: Die Verbindung wurde vom Kommunikationspartner zurückgesetzt

I am using since long time a switch to enable/disable a Thing in Openhab 2. This worked perfect.
Now since the last update 2.5.12 i got this error message i have shown above.
The command is:
/usr/bin/sshpass -p habopen ssh openhab@localhost -p8101 smarthome:things %2$s homematic:bridge:xxxx
Any idea what has changed in the last update

  • you are logged in to your OH system while executing the ssh command ? ( just asking because @localhost will only work in that way
  • this looks like it is being run from a rule. how does it behave if you all that from command line ?
  • does it work in this way:
echo "smarthome:things enable homematic:bridge:xxxx" | openhab-cli console -p habopen

Thanks for your answer.
No im not logged in, it will be done with an exec:command:input directly from Openhab.
I found a solution, looks like ssh has changed so if I add
-o StrictHostKeyChecking=No after the ssh in my command everything works fine.