Comments on Java test-drive

A community that is probably here because they want a setup that works, is stable and does not keep changing and having breaking changes. Who would have thought that same
Group would not want to trial changes that may break things? Sadly it’s been my experience that you need a new feature that people want, to get them to try something.

But seriously it would be great if users helped out to get the bindings tested and fixed before openhab 3 is released. Thanks for the initiative and the great work making it so easy to test it out. I found the upgrade easy minus the issue I reported on a second SD card. I had a working system with 1.5 hours of time which 90% was waiting for the install and cards to flash. So please give it a try out to help make the next release a good one. It is also a good experience to test your backups out to ensure they are working and to learn what to do when you need the backups for real.

Perhaps a summery of findings somewhere would be great to have that lists known issues and the work arounds? A list with the bindings that people have tried and work fine?

I tried and it is getting worse and worse: Java on non-openHABian I use the latest snapshot. It starts under Java 11 but it frozen due to njserial issue and Zwave binding does not work without solving it. New Rule engine needs to refresh Jython standalone to 272 but original 272 does not work we need a customized one by 5iver where jar file is not avaiable. I received his version but I can’t make java from that. I would not recommend to anybody to try it.

May I suggest that perhaps it is fine to try it unless you use the new rule engine which is known to have problems with Java 11?

Probably. I reached a point, where njserial issue was solved and Zwave binding started but I couldn’t fix the ruleengine issue.

Just one more thought why I wanted to change to Java 11. I did a try on Openhab 3 what works on Java 11. If I can use both Openhab2.5 and Openhab 3 on same Java then I sould not change Java settings all the time when I want to work on change to Openhab3. I do not believe on onetime change with a script.

There are no known issues with Java 11 and the new rule engine! However, there is a reported issue (I haven’t tracked it down yet) with manual installations of Jython and Java 11. This is not an issue when using an updated version of my Jython addon using 2.7.2, which I have not distributed yet, but can be built from the source in my PR.

I use jython for my rules and after chanhing the Java version i changed immediately back, because it simply does not work.

You must mention that you’re using Windows and you have hit a Windows specific problem with nrjavaserial that does not exist as such on Linux hence not on openHABian. Please help keeping communication clean and don’t cross-post into every related thread just because you’re frustrated.
I understand that but it isn’t helpful.

Just changed the JAVA version. So far everything seems to run very well. Many thanks @mstormi for paving the road for OH3 :+1:


You “must” read my comments before you judge anything and I’m very polite now. Java on non-openHABian
Not mentioning that I’ve shared complete debug logging etc.
If I would receive useful information would be helpful.
I was not frustrated at all up till now and I do not give up.
I would like to change to Java 11 still.

So now my system runs on java version “1.8.0_231”
Java™ SE Runtime Environment (build 1.8.0_231-b11)
Java HotSpot™ 64-Bit Server VM (build 25.231-b11, mixed mode)
Operating system windows10 and it runs on Intel NUC I7 8gb ram + ssd
openHAB 2.5.6 Build #139
I can start Openhab only with start.bat. It does not start as a service.
I get the following messages in karaf consol:
karafconsollog.txt (5.8 KB)
I use these bundles:
bundle_list.txt (19.9 KB)
DSL rules are working fine but NGRE rule engine does not start.
ruleengine.txt (5.0 KB)
I found another error log in userdata\catch folder: 1591735354178.log (2.6 KB)
It would be helpful to have a hint what I need to check for running Openhab as a service.
Tomorrow I try to fix NGRE rule engine.

1 Like

Off topic, this thread is about openHABian not openHAB on windows.

No. It means: please use a separate thread for your problem and don’t post into others’ threads unless you contribute to what’s the topic there.
The Java test-drive is on openHABian which is Linux ONLY as can be read in the original post.
This thread is just comments on that, so your posts do not belong here.
Hence also my request to keep communications clean.
As a moderator, I’m asking you to follow the community guidelines. Thank you for your cooperation.

Ok, as you wish.
Sorry I was reading it fast.

I just installed the 32bit version on pi3. Working like a champ!!

I like the new openhabian changes, repo related that is!

Question, can the 64bit be used on buster? Is there an advantage?

You mean 64 bit Java on a standard 32 bit OS ?
I guess it would work, but it’s neither tested nor recommended as it has nothing but disadvantages (larger memory consumption), that’s why openHABian refuses to install it like that.

@mstormi That is what I meant 64bit on 32bit OS. I went with 32bit as the most valid assumption for the 32bit OS, I picked correct. Thanks for info, missed the info the first time.

anyone experienced issues with the systeminfo binding, or is it just me?

I’m running on openhabian snapshot #141 with Zulu 32bit Java11 on a RPi4

The systeminfo thing is online, but i dont get item updates…

I set the log to DEBUG… but i dont get any error messages…

I have no problems running that under Zulu 11.

okay… good to know… will have a look what causes my systeminfo items to stop.