Community Marketplace not showing


The Community Marketplace is not showing for me.
I have tried disabling and re-enabling via the Settings page of the UI.
I have also tried deleting the tmp and cache folders, but I still don’t get the Community Marketplace
OpenHAB 4.0.0M2

Any ideas?

There were several similar reports from other people who have upgraded. I don’t remember exactly where, but look through the 4.0 snapshot and milestone threads, that’s probably where they are:

To save from needing to read through all those posts, (where indeed the solution is posted), if you’ve upgraded from 3.4 → 4.0 the format of one of the JSONDB files related to the marketplace changed. You need to stop OH, delete it and when OH restarts it will recreate it with the proper formatting.

My OH is dead dead dead right now so I’m going from memory.

Stop OH.

Navigate to $OH_USERDATA/jsondb (e.g. /var/lib/openhab/jsondb).

Delete the file that has “marketplace” in the name.

Navigate to $OH_USERDATA/jsondb/backups.

Delete any files there that have “marketplace” in the name.

If you neglect that last step, when OH comes up it will see the “main” file isn’t there and silently start using the most recent backup instead.