Complete Crash and strange @^@^ in event log

Dear Openhabians,

just when we left home for some days of vacation, my openhabian 2.4 (raspberry pi 3 b plus) decided to crash. It stopped working altogether, no ssh was possible.
When I came back home today I had to power-toggle the raspberry to get it up again.
Checking the event logs, they just stop at the moment of crash without any error. Then there are some (or a single long) lines with just:
and so on.
After that, the event log continues when the system was restarted.
Has anybody seen this @^ thing? Is it just something that is written to the logs on startup, or is it any indication of an error?

Thank you so much already,


I have seen this exact thing.

It happen when I was asleep. I got up, nothing worked, I turned on the monitor attached to the host OpenHAB was running on… nothing, blank black screen. I thought something had died, nope, restart host brings up OpenHAB. I check the logs, same as you describe, nothing unusual right up to @@@@@@@@ (all highlighted in red in fronttail)

No idea what caused crash, no power outage. Still have logs

The most likely causes for this behavior are:

  • Less than optimal power supply (that starts to play havoc under certain conditions (higher exterior temperature for instance or very brief power surge).
  • Bad block on SD card.
  • Memory leaks
  • Other software error.

@Andrew_Rowe: what version of OH are you running? Also 2.4 Release version?

I am on 2.4 stable. I do have a development zwave jar running. Install is months old. All has been stable for months. My host is Debian 9 on a desktop pc with i3 8Gbs ram and spinny 1Tb HD
Only other thing running on host is apache web server serving web page interface for OpenHAB locally only

Only thing in my case was I was experimenting with rules that night. Made many changes to rules files and reloaded then numerous times. Not all of them worked properly. I figured I got the thing sideways and crashed it. Restarting it cleared everything up so I wrote it off. Was a few weeks back

OK, that means a lot or reloading and triggering of SystemStarted events. Could be that the binding caused an error condition because of this…?

yes yes, I was actually working on a SystemStarted rule a few times. I also had some loops running on timers and expire binding stuff as well… I was experimenting

Similar case here, except for the rule experimenting, which I did not.
I had it stable for months with no big changes. Running the stock zwave binding.
My last event message is a hue thing that updated.
I have it all running on an SSD so the SD should not be the problem I guess?

I will try to investigate further…

I have had another incident and it happened some time after updating some packages via the openhabian-config. The last time, I also ran an update some hours before. I will see if it happens again next time I run updates.

I have had no further incidents of this kind

hmm… only clue
what packages?

I had the same problem every 3-4 weeks. I also run my openhabian 2.4 stable on a pi with an SSD boot.
I don´t know why I got this chrash every month.
OH crash on different time, different days, but every 3-4 weeks. after a reboot always works like a charm.

Did anyone find a solution?

I have been trying some things and right now it is quite stable. However, I can’t really tell what did the trick.
I had a rule that checked if a timer exists with if(timer) {…} and I felt like it might instantiate the timer var instead of checking if it exists. So I deleted it and additionally I removed some bindings I wasn’t using anymore. Maybe you could write what bindings you have running and I’ll check which ones I have and what I’ve removed!

I run Openhab as Openhabian 2.4 stable on a Raspi 3b with SSD Boot.
Here is my addons.config:


in additional the following bindings at addons folder:


I’m running on RPi3b as well. Having a look at your addons, I have kicked out the openhab cloud as I don’t use it. You could give it a try, if you don’t need it.

hmm well I need it. any other bindings you use?

What have you got a B in here?

good question, I don´t know.

Is there a way to output a summary in some way? I have installed my bindings via paperUI…