Complete Noob Insteon 2635-222

I am a complete noob when it comes to OpenHAB and I am unable to get any response from an Insteon 2635-222 switch. I have searched around and at this point, I’m not sure where to look.

Here is what I have done so far…

Edited the default configuration file and uncommented the following and added user, password, and IP.

This was the only thing that I changed there.

Then, I create a file test.items with only one item. I used the Insteon ID that I found on the app for the light switch.
Switch test “Test 1” {insteonplm=“36.07.5C:F00.00.1B#switch”}

Then, I copied an existing sitemap and renamed it test2 and added the following…
Switch item=test

I can see the switch listed on http://localhost:8080/ but, it doesn’t reflect the current state of the switch and doesn’t control the switch.

I added the code to add debugging information in the logback.xml file that creates insteonplm.log file. The file was created but, it is empty.

Any help would be greatly appreciated.


I assume you are using OH1? Anyway it looks like you don’t have the InsteonPLM binding in the addons directory. You should see something like the following if the binding is getting started:

2016-11-04 15:20:30.612 [INFO ] [insteonplm.InsteonPLMActivator] - Insteon PLM binding has been started.
2016-11-04 15:20:31.726 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - dead device timeout set to 3000s
2016-11-04 15:20:31.739 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: port_0 -> /dev/ttyUSB0
2016-11-04 15:20:31.747 [INFO ] [.service.AbstractActiveService] - InsteonPLM has been started
2016-11-04 15:20:31.809 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - devices:   0 configured,   0 polling, msgs received:     0
2016-11-04 15:20:32.038 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - config: -> org.openhab.insteonplm
2016-11-04 15:20:39.722 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - modem database has 61 entries!
2016-11-04 15:20:39.728 [INFO ] [.o.b.i.InsteonPLMActiveBinding] - device 23.9F.C9 found in the modem database and the modem controls groups [0xFE] and responds to groups [0x01].

Getting closer. Once I saw your message, I realized that I didn’t extract the files in the addons directory. Yes, I am using OH1. Here is what I am seeing now in the insteonplm.log file…

2016-11-09 18:24:04 INFO o.o.b.i.InsteonPLMActivator[:34]- Insteon PLM binding has been started.
2016-11-09 18:24:05 DEBUG o.o.b.i.InsteonPLMActiveBinding[:158]- activating binding
2016-11-09 18:24:05 DEBUG o.o.b.i.InsteonPLMActiveBinding[:243]- seems like our configuration has been erased, will reset everything!
2016-11-09 18:24:05 DEBUG o.o.b.i.InsteonPLMActiveBinding[:254]- config has not changed, done.
2016-11-09 18:24:09 INFO o.o.b.i.InsteonPLMActiveBinding[:125]- Item: test got command OFF
2016-11-09 18:24:09 DEBUG o.o.b.i.InsteonPLMActiveBinding[:128]- not ready to handle commands yet, returning.


Not sure if this helps diagnose but, I tried to telnet to port 25105 and it just hangs on Connecting to…

I used Zenmap to see what ports are open and it only lists 23 and 443.

Thanks again for any suggestions.

@Bernd_Pfrommer, any suggestions?

I would think I need to forward the port. I tried quickly before work this morning without success.