Completely Baffled - Synology

After most of the day slowly getting OpenHAB 2 installed and working on my Windows 10 PC as recommended elsewhere for beginners I felt the time had come to install it on my Synology DS215j. Alas it doesn’t seem to cooperate, at the end of the manual installation I receive the message “Get new version Processing openhab_2.1.0.zip” in a dialog box.

I have no idea what this means, I can’t find any reference to this message anywhere. The package center says that openHAB2 is running but when I select the appropriate link I just get a blank white page in my browser.

I have tried to find a solution but I am most definitely not a Unix/Linux command person, coming from a Windows background, and that as merely a user. Whilst I have tried to understand the help offered elsewhere it mostly goes over my head. I did try granting users read/write permission on the public folder but with no success, it remains empty.

Some of the Synology packages don’t install properly, so which one did you install?

From my own experience the 2.1 packages don’'t work, tho other people might have had them install ok.

I’ve just installed the latest 2.2 version (005) and that seems to work ok - tho I’m not sure if that includes the demo files (which you might have to download separately).

Am happy to give you any help I can.

Hi Neil,

Thanks for the help. I just followed the links on the openHAB pages to install the Synology/latest stable version. I read a few forum messages and added the jdk file and set the folder to r/w but without success.

I shan’t be able to have another look until the end of the week at the earliest but will get back to you as soon as I do if that’s ok.

Fyi: you can see which version of openhab you’ve installed in the Synology package manager.

Hi Neil.

You’re not going to believe it, but when I looked at the package manager today and clicked on the openHAB link it started, albeit extremely slowly, and it now looks like it might be working.

The only thing I have to figure out now is how to transfer the configurations that I set up in Windows to the NAS.

Thanks for offering to help.

no worries - it does take quite a while to fire up properly, can be as long as 5 minutes. Runs well enough after that on my DS214play.

You need to copy your windows conf files into your NAS’s conf. Depending which version you have and how it installed, those should either be in /volume1/public/openHAB2/conf or /volume1/@appstore/openHAB2/conf.

(you’ll need to SSH in to get at /volume1/@appstore/openHAB2/)

Thanks. Trying to review the documentation and remember what I did before .