CONBEE II // Openhab USB problems // USB device not detected correctly?

Hello there,

I am using openHAB 2.5.1-2

“in short i can’t connect the deconz while the conbee is connected to the raspberry”

i ordererd a conbee 2 to expand my smarthome system.

The Configuration was a bit tricky, I connected the USB stick to my main PC to test the whole setup with Xiaomi sensors.
first, I get the IP address which was my “home pc” IP address, and the API key
After that, I created the bridge in the .things file
I could also connect in openhab the gateway and add the sensors to my sitemap.
this works great

The next step was, to connect the Conbee with the USB port from the “openhab raspberry”
So after I connected the USB to a free USB slot I checked the USB devices with ‘lsusb’
The device is correctly discoverd with “Desden Elektronik”

I am not sure but I was able to create a new API key, cause i didn’t find the problem.
so the conbee is connected to the raspberry and I can start the POST Method and get as a response the “new” API key which I bind to my .thing

I can also add new things with binding.

But the things are not getting updated and I can’t connect with the conbee with my main pc.
This makes me very confused, the only thing I change was to connect it with the raspberry?

It looks like “something” works but 90% are not working when I do it like this.
I tried to reset it to get a new IP Adress for it while it’s connected to the Raspberry but this doesn’t work as well, I am not able to connect anymore.

I think its a network Problem with my Raspberry or a USB Problem?
Can someone help with it?

Greetings and thank u

IS conbee on the same pi as openHAB or different?

Are the sensors working in phoscon and/or the rest api? This needs to be fully working before connecting to openHAB.

HI :slight_smile:

Yes I plugged the conbee to the same PI where OpenHAB runs

The Sensors are only working, with the phoscon app when I plug the conbee to my main computer
Openhab is connected to the conbee with the bridge and the API

deconz:deconz:homeserver [ host=“”, apikey=“A8E22F0A25” ]

This connection works when the conbee is connected to the main computer
I can see the gateway as “thing” and the sensors.
Until the conbee is connected to the main computer :thinking:

maybe these steps are needed too?

cause i thought its included in the deconz binding from openhab
anyways, I completed step 1. and step 2.

how did you configure the setup for the serial interface name ? Could it be that you have a naming conflict ?


i fixed the issue

How did i fixed it ?

Error description:
conbee is not discovered when it’s connected to the rasp


1. USB-Access setting for User

 sudo gpasswd -a $USER dialout

2. Phoscon Public-Key import

wget -O - | \ sudo apt-key add -

3. APT-Repository for deCONZ configuration

sudo sh -c "echo 'deb \ $(lsb_release -cs) main' > \ /etc/apt/sources.list.d/deconz.list"

4. APT-packetlist refresh

 sudo apt update

5. check the usb port from your rasp
ls -l /dev/ttyACM0

the answer should look like this (important is the bold part)

crw-rw---- 1 root dialout 204, 64 Apr 11 09:56 /dev/ttyAMA0

6. Userrights

I’ve set the User rights for the Users openhab and openhabian, u can check the rights with:

id openhab 


id openhabian

if “dialout” is displayed for both then its ok -> if its not please add it to the user:

gpasswd -a USER dialout

after that restart and start deconz:

sudo service deconz start

now u should be able to find the phoscon webapp under the link

When it is opened, please do a “search” for device in any case, also when a gateway is already discoverd (in my case it was a demo gateway and i found the correct one after that)

When its done u are ready -> now follow the deconz binding

I hope this will help some :slight_smile: