Configuration Values for Eurotronic Spirit Z-Wave Thermostat not writable

Hi all,

I have recently updated my Openhab installation to openHAB 2.5.10 Release Build. Since then (at least I have noticed that a few days later) I’m not longer able to set the values for “LCD Timeout” and “Temperature Offset” for my Eurotronic Spirit Z-Wave Thermostats. Only the preconfigured values from the dropdowns are available, numbers can’t be entered. Same behaviour on Paper UI and Habmin.
My configuration is:

  • Rasberry Pi 4
  • Openhabian image (Raspbian GNU/Linux 10 (buster))
  • Z-Wave binding 2.5.10
  • Sigma Designs Controller Z-Wave Plus USB-Dongle

Any idea what the reason could be?


I have a similar setup, not based on Openhabian but RasPi4 and OH 2.5.10 also. Installation via apt and updated from the previous OH versions step by step. ZWave binding is 2.5.10 also:
236 │ Active │ 80 │ 2.5.10 │ openHAB Add-ons :: Bundles :: ZWave Binding

And I can confirm that the 2 parameters mentioned can only be set as described. For parameter 2 (LCD Timeout) I can only select “No Timeout LCD always on”, I cannot edit the field to enter e.g. “5” for a timeout of 5 seconds.
For parameter 8 (Temperature Offset) it is similar, only “Use ext. temp. sensor” is offered/clickable, the field cannot be edited to enter a fix offset value.

This is likely a misconfiguration in the device database that will take a couple clicks to cleanup. Have you looked at the database entry? Specifically, there is a checkbox to allow manual entry for an option.

I’ll take a look when at a computer, but you can fix this yourself… just request an account.

1 Like

The database entry was modified but it was not marked for review. The changes i was suggesting appear to be included. I need to check on something, but i’ll be back.

There’s another discussion about this elsewhere in the forum. Some changes were made incorrectly, and now we need to reverse them but there are some issues with the database that need to get resolved and this might take some time.


Thanks @5iver for checking. I don’t have an account yet for the new database but will request one in the near future. Wanted to do that anyway, so this may be the trigger to do it finally :wink:
@chris: where can I check for information whether the issues you referred to are resolved? Don’t want to add to your workload as I do not need this to be fixed urgently. I only wanted to support the OP with his issue and cannot say how urgent it is from his p.o.v.

Hang tight… there is some cleanup needed in the database. Here is the other topic…