Configure HomeKit Integration loosing port

Hi all,

i have the following lines in homekit.cfg, but if i restart OH2, the port number is lost an i have to enter it again and again manually in Paper UI:

org.openhab.homekit:port=9124
org.openhab.homekit:pin=031-45-154
org.openhab.homekit:useFahrenheitTemperature=false
org.openhab.homekit:thermostatCoolMode=CoolOn
org.openhab.homekit:thermostatHeatMode=HeatOn
org.openhab.homekit:thermostatAutoMode=Auto
org.openhab.homekit:thermostatOffMode=Off
org.openhab.homekit:networkInterface=192.XXX.XXX.XX

Is there a short way to fix it for me?

Regards
Heiko

Same here! Solutions?

What exactly does this mean? I also notice that the Paper UI does not display it correctly, but when clicking the “Expert Mode” button, see that the port is still correctly set. I have entered https://github.com/eclipse/smarthome/issues/1313 to fix the Paper UI, but I think that this should not have any direct impact on the functionality of the HomeKit add-on.

You are right, it works a expected - i noticed after some OH2-Installations from the scratch without checking this parameter in the GUI.

A good idea to avoid users/testers like me from confusion :wink:

1 Like