Configuring ABB IPR/S3.1.1 KNX IP Router

Perfect. Now you can program using the interface that I showed earlier

Well I got a USB KNX unit since I couldn’t get the IP Router working previously and when I hit download on the IP Router ETS tells me to press the programming button, then it continues and soon finishes without any issues. But just as before I can see the IP Router on my network, I can ping it, but ETS doesn’t discover it and neither does the ABB i-bus tool so I am not sure what is going on there.

I will try again once I get home in a few hours, thank you so much for your assistance in this so far, I really appreciate it.

So everything seems to work when downloading but something is wrong. When programmed the IP Router should get picked up by ETS and it should also get picked up by i-bus tool. I tried setting manual IP on the router, confirmed it was set by pinging the device. Then I hooked my computer and IP Router to a switch isolating just these two units with the same result, firewall completely disabled, I can only ping it. When trying to use i-bus tool to connect over KNX to the IP Router, it returns “device is not supported” which is strange since it definitely should be.

I never used i-bus tool what advantage does it bring over ets ?
Then for the second question that you cannot connect to the router that I don’t know it should in theory allow 5 tunneling connections above the routing is that what you mean ? Maybe show how the device is placed in the topology and it’s settings.

It is used for firmware updates and settings like unicast. I cannot establish a connection to the Router still.

Topology and settings:




And what do you see as connections when you go to the little wagon sign on the right top .

Nothing except for my USB to KNX device, I mean no discovered connections.

I really have no idea what can be wrong. It’s also very difficult to know what you did etc. maybe try getting a local knx installer to help you otherwise without having acces in your setup I cannot help you further maybe another person on the forum has catch the error…wait and see I guess

Me neither, thank you so much for all the help though, much appreciated. What bugs me is that neither ETS or i-bus tool can discover the IP router, I don’t know if the router might be faulty since I purchased a used one.

Seems a legit option. :confused:

It’s really bizzare that he doesn’t have the option of chosing the network card for broadcast. The thing about the device being second hand I will not bet on it I believe something with his windows because he even tried doing it just with a switch. Best thing he can do is call an knx installer in his area to get it running.

As it’s used, maybe the IP address is configured to static. Then you wouldn’t find the ip if it’s in another subnet.

Try to reset the Device to default values:

  • Press the Programming button when the KNX bus is not connected.
  • Hold the Programming button down and plug on the bus terminal. The Programming LED flashes (2 Hz)
  • Press the button, hold it for at least 5 s and then release it. The Programming LED goes out, and the device reboots with the factory settings.

I couldn’t find any reset instructions in the manual for the device, where did you find these? However it accepts my programming because when assigning IP I can ping that IP on the network and get a reply, and when set as DHCP the device gets assigned an ip adress which I can find on the network and also ping. It’s just that the autodiscovery isn’t finding the device in the mentioned softwares.

When I did a test with just my computer and the router connected to a switch I set a static IP on the IP Router with my computer as gateway and vice versa but still didn’t detect it.