Congrats 2.5.0.M2

Yes, I did.
But I expected, that when I removed it from the cfg, that I will be de-installed, and disappear from paperu-UI, which did not happen. So I de-installed/installed it.

Now after restarting of OH i still have these entries. I think I have to ignore them.

2019-08-18 16:59:15.205 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed
2019-08-18 17:00:15.142 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed
2019-08-18 17:01:15.184 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed

remark: I modified the cont-init.d script to not adds misc entry.

Apologies for dragging up this topic again. but I’m seeing this exact issue as well, and with some more annoying bugs that might be related.

I installed M2 via. openhabian-config menu. The system is a Rpi3b+ with the openhab distro.

I can control things just fine, but when I try to search in my inbox for anything, regardless of binding, i get a “ERROR: 503 - Service Unavailable” but nothing is written in my log files.

I’ve already attempted to clear my cache with no changes.

That can be anything then, eventually it’s even not related to changes in 2.5M2.
Please debug your issue (raise log levels for org.eclipse.xxx.* and org.openhab.xxx.* as a first measure) and open a new thread (or go right to GitHub if you believe you found a bug). But a “me too” with such a vague description doesn’t help anybody get anywhere.

2 Likes

Did your problem dissappear eventually? I have exactly the same, but no trace of ‘openhab-ui-dashboard’ neither in /var/lib/openhab2/config/org/openhab/addons.config nor addon.cfg. They are both not modified.
I have the log entry every 60s. Anywhere else to look?
Thx

I upgraded to 2.5.0.M6 and the issue still exists.

Hi,
the message disappeared today. I’m not sure what the cause was, but I think the upgrade to the latest snaphot. I also changed some debug output back to default for these:

openhab> log:set DEFAULT org.eclipse.smarthome.binding.mqtt
openhab> log:set DEFAULT org.eclipse.smarthome.io.transport.mqtt
openhab> log:set DEFAULT org.eclipse.paho.client.mqttv3
openhab> log:set DEFAULT org.openhab.binding.mqtt

but I guess this is not related.
Good luck :slight_smile:

I’m getting this too constantly repeating after installing stable 2.5:

2019-12-20 14:56:52.208 [DEBUG] [core.karaf.internal.FeatureInstaller] - Running scheduled sync job
2019-12-20 14:56:52.455 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed

I’ve cleared the caches, restarted, deleted the addons.config file and so on.

Everything seems to get loaded okay, HABpanel even works. I then get the above message every minute and everything stops working.

Prior to that, after the first couple of restarted, HABpanel would load but any textual item was not linked to a HABpanel icon.

This all starts after the bindings etc are installed:

2019-12-20 15:25:53.603 [DEBUG] [core.karaf.internal.FeatureInstaller] - Installed 'openhab-binding-hue, openhab-persistence-mapdb, openhab-binding-nest, openhab-misc-openhabcloud, openhab-persistence-influxdb, openhab-binding-amazonechocontrol, openhab-misc-hueemulation, openhab-ui-habpanel, openhab-action-pushover, openhab-binding-mqtt, openhab-transformation-map, openhab-binding-rfxcom, openhab-binding-lgwebos, openhab-binding-kodi, openhab-ui-habmin, openhab-binding-homematic, openhab-ui-paper, openhab-binding-mail, openhab-transformation-jsonpath, openhab-binding-mihome, openhab-binding-miio, openhab-binding-wifiled, openhab-misc-gcal1, openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-astro, openhab-binding-expire1'

2019-12-20 15:25:56.159 [DEBUG] [core.karaf.internal.FeatureInstaller] - Running scheduled sync job

2019-12-20 15:26:22.243 [DEBUG] [core.karaf.internal.FeatureInstaller] - Installed 'openhab-binding-hue, openhab-persistence-mapdb, openhab-binding-nest, openhab-misc-openhabcloud, openhab-persistence-influxdb, openhab-binding-amazonechocontrol, openhab-misc-hueemulation, openhab-ui-habpanel, openhab-action-pushover, openhab-binding-mqtt, openhab-transformation-map, openhab-binding-rfxcom, openhab-binding-lgwebos, openhab-binding-kodi, openhab-ui-habmin, openhab-binding-homematic, openhab-ui-paper, openhab-binding-mail, openhab-transformation-jsonpath, openhab-binding-mihome, openhab-binding-miio, openhab-binding-wifiled, openhab-misc-gcal1, openhab-persistence-rrd4j, openhab-ui-basic, openhab-binding-astro, openhab-binding-expire1'

2019-12-20 15:26:27.618 [INFO ] [ipse.smarthome.model.script.Intruder] - gwin received update

2019-12-20 15:26:41.832 [DEBUG] [core.karaf.internal.FeatureInstaller] - Uninstalled 'openhab-ui-dashboard'

2019-12-20 15:26:42.058 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed

Does anyone have any ideas of what to try next?

Thanks!

After one more reboot cache clear, HABpanel is now up and working and items are linked but I am still getting the following every minute:

2019-12-20 16:18:32.445 [DEBUG] [core.karaf.internal.FeatureInstaller] - Running scheduled sync job
2019-12-20 16:18:32.649 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed

I’ve got a UI failure now:

2019-12-22 11:28:53.370 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed                                                                           uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is n                                                                          ot installed
2019-12-22 11:29:53.088 [DEBUG] [core.karaf.internal.FeatureInstaller] - Running                                                                           scheduled sync job
2019-12-22 11:29:53.386 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed                                                                           uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is n                                                                          ot installed
2019-12-22 11:30:53.097 [DEBUG] [core.karaf.internal.FeatureInstaller] - Running                                                                           scheduled sync job
2019-12-22 11:30:53.330 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed                                                                           uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is n                                                                          ot installed

Has anyone else seen this after a 2.5 install?

Rules etc are still working behind the scenes but HAB panel and any other UI are unusable.

I really do not know what else to try. Thank you for any assistance.

Check your config for the RestDocs, those moved from MISC to UI and can cause reloading parts of your installation every minute.
Check the release notes as well:

### Breaking Changes that Require Manual Interaction after the Upgrade

#### REST Docs

This add-on is now part of the UIs. When previously installed using a UI, uninstall the REST Docs before updating and reinstall it after the update to prevent errors. When installing it using textual configuration, update `services/addons.cfg` by removing `restdocs` from `misc` and add it to `ui` instead.

Thank you for your reply…

I did not have REST docs installed.

I didn’t add it to the services/addons.cfg folder but have now and am trying a restart.

I did read the docs but must have missed the last bit of this.

If this doesn’t work then I suppose I’ll have to do a complete re-install but is that likely to fix it? (The restart and cache clear didn’t work).

Re-reading the Manual changes required, I think this is what is causing a lot of confusion when upgrading:

Breaking Changes that Require Manual Interaction after the Upgrade

and then followed by:

REST Docs

This add-on is now part of the UIs. When previously installed using a UI, uninstall the REST Docs before updating .

I confess that I didn’t read that section until after the upgrade!

Please do this ONLY if you have configured your setup through addons.cfg in general.
addons.cfg takes precedence over your PaperUI configured setup.
If you only put the RestDocs in your addons.cfg, after the next restart everything else will be uninstalled.

I had configured it in addons.cfg (but with the other stuff also in there).

That didn’t work. I tried commenting out everything in addons.cfg but then after a restart, I didn’t have a UI.
Finally, I un-commented package = standard, cleared the cache and re-started, and the UI problems and messages have gone.

Of course I needed to re-install the bindings after this. I did it through PaperUI as, to be honest, I still don’t know what caused the problems in addons.cfg.

Anyway - all is OK now so thanks for your help.

I had exactly the same behaviour. Studied my addons.cfg a million times but no weird stuff. After disabling everything in addons.cfg still no change, deleted cache, reboot etc etc.
Solution: I stopped openhab, deleted the addons.CONFIG file, which is generated based on the addons.cfg file. Deleted the cache and started openhab. After that the error was gone!

Kind regards Han

1 Like

After a restart, mine’s doing the ui thing again.

Nothing to do with restdocs as these are in U.I.

2020-01-09 17:48:20.355 [DEBUG] [core.karaf.internal.FeatureInstaller] - Running scheduled sync job
2020-01-09 17:48:20.695 [DEBUG] [core.karaf.internal.FeatureInstaller] - Failed uninstalling 'openhab-ui-dashboard': Feature named 'openhab-ui-dashboard/0' is not installed

A commented out addons.config and a deleted addons.cfg resulted in none of the UIs being installed upon a restart.

They got installed when I used my old addons.config and now things work again but I get the error message every minute.

Here’s my addons.config if it helps:

# The base installation package of this openHAB instance
# Note: This is only regarded at the VERY FIRST START of openHAB
# Optional. If not set, the dashboard (https://<yourserver>:8080/) will ask you to choose a package.
#
# Valid options:
#   - minimal  : Installation only with dashboard, but no UIs or other addons
#   - simple   : Setup for using openHAB purely through UIs - you need to expect MANY constraints in functionality!
#   - standard : Default setup for normal users, best for textual setup
#   - expert   : Setup for expert users, especially for people migrating from openHAB 1.x
#   - demo     : A demo setup which includes UIs, a few bindings, config files etc.
#
package = standard

# Access Remote Add-on Repositories
# Defines whether the remote openHAB add-on repository should be used for browsing and installing add-ons.
# This not only makes latest snapshots of add-ons available, it is also required for the installation of
# any legacy 1.x add-on and all experimental features. (default is false for offline distro, true for online distro)
#
remote = true

# Include legacy 1.x bindings. If set to true, it also allows the installation of 1.x bindings for which there is 
# already a 2.x version available (requires remote repo access, see above). (default is false)
#
legacy = true

# A comma-separated list of bindings to install (e.g. "sonos,knx,zwave")
binding = mqtt1,kodi,homematic,astro,rfxcom,hue,wifiled,mihome,miio,nest,lgwebos,amazonechocontrol,mail,expire1



# A comma-separated list of UIs to install (e.g. "basic,paper")
ui = paper,habmin,habpanel,restdocs


# A comma-separated list of persistence services to install (e.g. "rrd4j,jpa")
persistence = influxdb,rrd4j,mapdb

# A comma-separated list of actions to install (e.g. "mail,pushover")
#action = mail,pushover,mqtt1
action = pushover


# A comma-separated list of transformation services to install (e.g. "map,jsonpath")
transformation = map,jsonpath

# A comma-separated list of voice services to install (e.g. "marytts,freetts")
#voice = 

# A comma-separated list of miscellaneous services to install (e.g. "myopenhab")
misc = hueemulation,openhabcloud,gcal1

Any help or guidance gratefully received!

Thanks

It wos quite hard but I found the problem.
This is what I have done:

  1. Stop openHab
  2. Backup addons.config and dashboard.config from /var/lib/openhab2/config/org/openhab/
  3. Delete original files addons.config and dashboard.config
  4. Restart openHab
  5. Go to http://myserver:8080
  6. Select Standard installation, at this point both files are recreated

Checking the two files recreated i found that:

  • dashboard.config have one line more than the previous one
  • addons.config have only few lines compared with my old one but i noticed that the ui line was different:
    this is the old one, ui="basic,paper,habpanel,habmin"
    this is the new one, ui="dashboard,basic,paper,habpanel,habmin"

Then I stop again openHab reinstall my old addons.config file with the correct ui line and restart.

Now the error is gone.