Connecting Velux Active KIX 300

I’m also interested in this, as well as some examples. :slight_smile: I never managed to set the home/away status, this would be the absolutely most interesting thing for me.

Any ideas on this?

If you still struggle with setting up your Thing:
The definition file is (if you created it with the help of the above mentioned tutorial) not located in the folder where the EXEC is running. Therefore change the Thing command to where the file is (probably standard startup of SSH)

python -m homekit.put_characteristic -f /home/openhabian/velux -a velux -c 3.11 0 -c 5.11 0


Do you know where I can find “sign_key_id” and “sign_key_id”?


I think it is required to sniff the network traffic of the app as desribed in post 11

Found the “SignKeyId” and the “HashSignKey”, when calculating the “hash_target_position” according to GitHub - ZTHawk/velux_active_patches I get Error 9 when sending. Anyone has some idea what might cause that?


I am trying to use the solution based on the “HomeKit” approach, as explained above.

I am executing the following command inside a rule

var String veluxShutter
veluxShutter = "2.11"
var int position
position = "50"

val String Answer = executeCommandLine(Duration.ofSeconds(2),"python3","-m","homekit.put_characteristic","-f","/home/openhabian/velux","-a","velux","-c",veluxShutter,position)

logInfo("shutters", "Result:" + Answer)

When I trigger the concerned rule an error is triggered and the outcome in the log is the following:

Result:/usr/bin/python3: Error while finding module specification for 'homekit.put_characteristic' (ModuleNotFoundError: No module named 'homekit')

I understand that the execution folder of the “executeCommandLine()” is not the one where the module is stored. However, I am not able to address the execution to a diffrent folder.

Anyone would have an idea on how to make it?

Comment added later:

I realized that the user for the executeCommandLine() is : “openhab” and the module homekit is not available for this user. (sudo -u openhab pip list)

In this page:

The installation makes use of the key “- -user”

I run again the installation of the homekit module with
sudo pip3 install homekit…
and now the module is available also for the user openhab.

Issue solved!