Constant ZWave Serial Port in Use all of a sudden

Hi All

This constantly happens now. No changes to the system

Does anyone know why this occurs?

'zwave:serial_zstick:d51cc026' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): Serial Error: Port /dev/ttyACM0 is in use

its hit an miss in terms of when it goes online/offline, but requires an entire reboot for it to come up, then it breaks again, randomly.

OH 2.4.0, 2.5.0 Snapshot binding.

This is in my openhab file


and this in my udev rules

	SUBSYSTEM=="tty", ATTRS{idVendor}=="0658", ATTRS{idProduct}=="0200", SYMLINK+="ttyUSB-ZStick", GROUP="dialout", MODE="0666"

Again, worked for years, no suddenly it starts to break.

:~$  dmesg | grep tty
[    0.000000] console [tty0] enabled
[    0.719967] 00:01: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
[    5.006409] cdc_acm 1-6:1.0: ttyACM0: USB ACM device

PaperUI says under the ZWave Stick Thing

tty/ACM0 does not exist

I’ve also further noticied after reports, transport-serial just uninstalls itself.

FINALLY, when it does come online, for how long

I see this in the log and cant control any lights

[openhab.binding.zwave.internal.ZWaveConfigProvider] - No bridgeUID found in getConfigDescription thing:zwave:serial_zstick:d51cc026


Hmm, not even OS upgrades?

Hi Kris,
you did not mention which Linux you use. It might help the supporters here knowing that.

From my point of view;
You have a udev rule in place without using the result at all. Your rule would provide the name for the Z-WAVE controller device as “ttyUSB-ZStick”. But a few lines further down you mention “tty/ACM0” as the configuration for the interface device in PaperUI. That does not match as far as I see.

“tty/ACM0” should be “/dev/ttyACM0” if that really is the device name for your Z-Wave controller.

If I would be in your shoes I would do this:

  • get rid of the udev rule, reboot your device with the Z-Wave-controller unplugged
  • check which devices are listed in “/dev”
  • plug in the Z-Wave controller and check the devices in /dev again. The device that is showing up in comparison to the state without the controller being plugged in is your Z-Wave controller
  • configure this additional device in PaperUI
  • make sure, the openhab user (which most likely is running the openhab installation) is a member of the “dialout” group
  • reboot your device again and check if it works

(remark: currently I have an issue to login into my own RasPi to check my advice, so it might not be entirely correct, I will try to correct that asap)

Found the issue blocking me from logging into my device…
My Z-Wave-stick is device “/dev/ttyACM0”. It should look similar in your case. But “tty/ACM0” does not look correct, the “/” is not ok here, assuming Linux distributions work similar in providing device names.

Sorry gents, i tried different names, ACM0, ZStick, it was consistent despite my pasting errors.

Ubuntu 18. No software updates

Left it over night, no nodes online despite them starting to come up when I went to bed. Woke up and they are all offline. So i restarted the binding and again

'zwave:serial_zstick:53f5472c' changed from OFFLINE (BRIDGE_OFFLINE): Controller is offline to OFFLINE (COMMUNICATION_ERROR): Serial Error: Port /dev/ttyUSB-ZStick is in use


paste error

its /dev/ttyUSB-ZStick

Try “sudo lsof /dev/” to find out which process uses the controller. In my case (RasPi OS) it is java with user openhab as it should be:

java        504          openhab  176u   CHR  166,0      0t0  250 /dev/ttyACM0

Yes, its with Java

java 958 openhab 98u CHR 166,0 0t0 442 /dev/ttyACM0

Kris, when you reboot your system, you can control your devices?

I’m wondering whether it is really randomly or rather something that is caused by energy saving configurations. But that is a field I am not familiar with. Hopefully someone else can assist.

When I reboot it comes back for a few hours, then disappears again and the nodes go offline. Im at a loss as why this is so darn hard to fix.

I suggest to look for entries of “power” and/or “suspend” in your system log. Maybe that gives a hint of what the issue may be.
And this website may possibly help.

1 Like

So it APPEARS as if something is changing mid way through Zwave coming up, because I see this in the logs:

No bridgeUID found in getConfigDescription thing:zwave:serial_zstick

Everything breaks once this occurs.