CoolMasterNet Binding Fan Speed not working

I am using the coolmasternet binding to control my Daikin Aircon Units.
Initially I could not get the mode changed until I found out that the commands need to be in lowercase; auto, cool, dry, fan
This was not specified in the documentation.

But the real problem is that I can not get the fan mode to work.
The documentation states that the channel will be called “fan_speed" but OpenHab creates a channel called “fan”
I tried both names in my Items, but no luck, I also tried a variety of commands like l,m,h,a vs “low”,”medium”,”high”,”auto”
In the PaperUI the Fan Control also doesn’t work.
There may be a bug in this add-on and I hope someone can help me shed a light on it.
I could not find anything in the log files.
For the record, if I log into my cool master net with telnet then I can control the fan speed without any problem.



@Beginner I’ve created the following PR for this issue:

Was this ever resolved?? Github link doesnt work

Yes, this is resolved. there was an inconsistency in the documentation.
Below is an example of my own sitemap for the Aircon.
Where the settings will only be visible if the aircon is on.

    Switch  item=GF_Dining_AirCon label="Dining Room Aircon"
    Setpoint item=GF_Dining_Heating  minValue=21 maxValue=30 step=1 label="Dining Room [%.0f °C]"visibility=[GF_Dining_AirCon==ON]
    Switch  item=GF_Dining_AirconFan label="Fan Speed" mappings=[l="Low", m="Medium",h="High",a="Auto"] visibility=[GF_Dining_AirCon==ON]
    Switch  item=GF_Dining_AirconMode label="Mode" mappings=["cool"="Cool", "dry"="Dry","fan"="Fan Only"] visibility=[GF_Dining_AirCon==ON]
1 Like

Thanks I had managed to work that out also after a bit :wink: when I saw the status was l or m :wink: