Could not create rrd4j database file

Hello,
I’m using OH2, with rrd4j and getting lots of errors with some (most of them is ok) of my items.

[ERROR] [sistence.rrd4j.internal.RRD4jService] - Could not create rrd4j database file ‘/var/lib/openhab2/persistence/rrd4j/washingMachineWatts.rrd’: sync failed

Using REST I can see the value of the item in rrd4j presistence, but still my log is full with errors…

I’ve tried to delete the file, didn’t help.
Does anybody has any idea how to solve it?
Thanks ahead.

Could you post the files which configure rrd4j and the item definitions?

Yes:

Strategies {
everyMinute : "0 * * * * ?"
everyHour : "0 0 * * * ?"
everyDay : "0 0 0 * * ?"
default = everyChange
}
Items {
*Watts, *Temprature : strategy = everyChange, everyDay, restoreOnStartup
* : strategy = everyChange, everyHour, restoreOnStartup
}

rrd4j needs a strategy for every minute.
rrd4j does only persist numerical data, you have strategy for all items!
You did not show your rrd4j.cfg file.

The problem is with numerical data (float)
my rrd4j.cfg is empty (only comments…)

The last line in that file (xxx.items…) defines which items are persisted!

Yes, but by default all the items persist

In this case I have to repeat my first statement.
rrd4j needs a strategy every Minute which you do not use.

At the beginning it was every minute and then night log was filled with errors so I change it to every hour…
It wasn’t working even with one minutes

Did you find a solution? I have the same problem since I persist my cpu load of my raspberry. I am using openhabian with a raspberry pi 3 and as well I persist everyMinute.

20:03:28.544 [ERROR] [sistence.rrd4j.internal.RRD4jService] - Could not create rrd4j database file '/var/lib/openhab2/persistence/rrd4j/Systeminfo_openhabian_Cpu_Load.rrd': sync failed

Thank you for your help!

I don’t have a solution…

Hi @Ahiel @johannesbonn

For example to you :

rrd4j.cfg file :

Strategies {
everyMinute : "0 * * * * ?"
everyHour : "0 0 * * * ?"
everyDay : "0 0 0 * * ?"
default = everyChange
}
Items {
* : strategy = everyMinute, everyChange, restoreOnStartup
}

demo.items file :

Number MyReport “Report”

I think your item name should have no “_” in your item name.
Ex: MyReport is OK
My_Report isn’t OK

Try it and good luck :slight_smile:

My items has no underscore…

Unfortunely!

In my case, it is OK.
You can try in new OH2 to check it.

Regards

I have tried with a new openhabian image… still the same…

Did you check the Karaf-Console? Try setting the logging-level of rrd4j to debug.

Well I moved to influxdb… (because of that and because of grafana…)