Creating my first rule with OH3, not working as expected

Hi everyone. I am starting from scratch setting my system up with OH3. My previous OH2.x is full of unused items, long abandoned things and rules and just needed to be scrapped.

I am making a simple rule, that will use some ZWave devices: an Aetoec Wallmote Quad and a GE in Wall Dimmer.
This rule is not working and am scratching my head about it, as it seems to be so simple I’m not sure what is wrong.
Can anyone take a look and see if my logic is wrong, or if I am not using the conditions correctly?

If I press the button on the WalmoteQuad, Scene is reported pending on which button, and I can control the GE WallDimmer switch as well.

I have both things setup and functioning and am trying to create my first rule using the GUI.
What I am trying to accomplish:

  1. Wallmote top left button is pressed, Scene reports as “1”.
  2. With the rule using that Scene 1 is pressed, turn off GE Wall Dimmer.

Here is a screenshot of the Rule, and the YAML code it generates.


  • id: “3”
    state: “1”
    itemName: ZW028_WallMoteQuad_SceneNumber
    type: core.ItemStateUpdateTrigger
    conditions: []
  • inputs: {}
    id: “2”
    itemName: ZW009_Switch_Dimmer
    command: “0”
    type: core.ItemCommandAction

I haven’t used OH3 UI for rules yet, but using your switch does it command or update your Item? At the moment your rule will only trigger on an update.

Do you have an option which simply triggers on a change (to 1)? You may want that for now…

Thanks @hafniumzinc that is what I would think should happen with the rule. The way I am reading it in the GUI creation is the condition will trigger when the state updates (to 1) as this is what the button press reports when looking at the logs. I am not commanding it to a value of 1.
In order to have it as a true condition with “change”, it would need to be changed “from” and “to”. There are too many combinations to have this evaluate with unless i can use NOT (!) in the rule condition, which I haven’t figured out either. However I have tried a condition of changing from 2 to 1 and the rule still does not function.


You don’t need both. Either one is also an option. So in your case you only have to fill in to 1 and leave the from empty.

Thanks Laurens I tried that as well after I posted my last message. The wording under the “from” says required however that must mean it is a required only condition for the rule.
Still no luck though…


I figured it out, was a matter of misconfiguration.
The condition was never evaluating properly due to it not looking for the correct match.

The condition should be checking for “#.0”, eg. 1.0 not “1”.

After correcting this the rule runs properly.

Thanks everyone for your suggestions to diagnose…