CUL + Intertechno PowerPlug Setup

Hi Guys,

i try to switch my Intertechno Power Plugs (IT 1500) with OpenHAB. (openhabian)
Please help me to get it to work - i am using this CC1101 with 464 MHz.

  1. installed my selfmade CUL Stick with this tutorial:
  2. did no changes in board.h ( #define HAS_CC1100_433 )
  3. installed CUL correctly -> „avrdude done. Thank you„.
  4. plugged in my CUL via USB.
  5. installed the intertechno binding

in TERMINAL “lsusb” says:

Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

in TERMINAL “ls -l /dev/serial/by-id” says:

total 0
lrwxrwxrwx 1 root root 13 Nov 19 15:54 usb-FTDI_FT232R_USB_UART_A9E5XZFJ-if00-port0 -> ../../ttyUSB0

my culintertechno.cfg

############################# Intertechno Binding ###################################
# Devicename to use (mandatory)
# Example /dev/ttyACM0

# How often should the command be repeated? (optional)
# See for details

# How long should one pulse be? (optional)
# See for details

my item ( i found that code in the web, dont know if its correct )

Switch Cultest1 "Cultest1" { culintertechno="type=raw;address=1FF1FF0FF;commandOn=FF;commandOff=00" }

my log

2017-11-19 16:42:27.259 [WARN ] [io.transport.cul.CULLifecycleManager] - CUL config is NULL, doing nothing
2017-11-19 16:42:27.628 [INFO ] [ternal.serial.CULSerialConfigFactory] - Update config, baudrate = 38400
2017-11-19 16:42:27.631 [INFO ] [ternal.serial.CULSerialConfigFactory] - Update config, parity = NONE (0)

How do i find out the right “Adress” of my Plugs ?
How do i get it to work !?

Could someone guide me here please - thank you!

What plugs do you? What code is set to them?
Did you look Here?

i have those - there are no “code-switches on the backside” :

and i looked into the FHEM-Intertechno-Page:

as i understand the page, i should send an ON-value to the plug in the first 5 sec. when i gets plugged in, to get paired with my “item-adress”
but i dont know how to do so…


i installed “minicom” and edited to “ttyUSB0 - 38400 8N1”

i rebooted openhab

now i get this in my minicom after typing


/enter ( CUL Version )


/enter (spoofing)

and pressing the buttons on the remote-control

Welcome to minicom 2.7

Compiled on May  7 2017, 05:18:49.
Port /dev/ttyUSB0, 17:59:27

Press CTRL-A Z for help on special keys

00 1818
00 1818
00 1818
V 1.67 nanoCUL433

Since I do not have one of those “moden” switches (mine are >25 years old!), I can’t tell for sure!

I would try it this way:

Create an Item that sends only “ON” code (in order to send a real long ON code by sending more often) using a selfmade code like:

Switch SetUP_OnlyON “SetUP” {culintertechno=“type=raw;address=10101010101010101010101010;commandOn=000011;commandOff=000011”} /* TestSignal to pair the powerplugg last 4bits as if Button4 was pressed*/

After that power-plug is paired that way the following switch should switch the plug ON/OFF

Switch Plug_One “Plug_One” {culintertechno=“type=raw;address=10101010101010101010101010;commandOn=010011;commandOff=000011”} /* Switch that is paired to Plug_One last 4bits as if Button4 was pressed*/

I used the channelID four Button 4, if you pair other plugs with the same starting code and other button codes, you should be able to use the ALL-codes!

PS: It took a while to find an old thread about that and then some real world dropped in.

1 Like

i am a bit further now - i found this thread with the minicom info

i found the phyton-script here

installed with that


my Terminal says this now:

python i66A5A5566A55955519

The string to enter in your serial terminal is:

The id of your remote control is:

The group flag is:

Your device was set to:


inside the minicom i can now turn my Plugs ON / OFF with that

ON = "is01011100110000010111000010010000"
OFF = "is01011100110000010111000010000000"

but my item isnt working:

Switch Cultest4 "Cultest4" { culintertechno="type=raw;adress=01011100110000010111000010010000;commanOn=010000;commandOff=000000"} 

In this case a working switch should be:

Switch Plug_One “Plug_One” {culintertechno=“type=raw;address=01011100110000010111000010;commandOn=010000;commandOff=000000”}

Glad you got it working!

1 Like

Thank you :slight_smile: but this one isnt working :frowning:

Switch Cultest4 "Cultest4" { culintertechno="type=raw;address=01011100110000010111000010;commandOn=010000;commandOff=000000"}

The CUL-Stick is working (otherwise you couldn.t have actuate the switch with minicom)
The CUL-Stick is recognised by OH (as of reading the log posted above)

What does the log show when actuating the Cultest4?

[Edit:] Did you close minicom, or even better restart the system after closing minicom. I do remember some problems when doing my testing using “screen”.

1 Like

okay that helped and worked - i closed minicom and rebooted
now the Cultest4 is switching :slight_smile: YESSSSS - success :slight_smile:

THANK YOU @opus !!

i have also found out whats the address for all 3 Plugs now :slight_smile:

Switch Cultest4 "Cultest4" { culintertechno="type=raw;address=01011100110000010111000010;commandOn=010000;commandOff=000000" }
Switch Cultest5 "Cultest5" { culintertechno="type=raw;address=01011100110000010111000010;commandOn=010001;commandOff=000001" }
Switch Cultest6 "Cultest6" { culintertechno="type=raw;address=01011100110000010111000010;commandOn=010010;commandOff=000010" }
1 Like

my OH crashed and i set it up new.
log says same as 2017

2017-11-19 16:42:27.259 [WARN ] [io.transport.cul.CULLifecycleManager] - CUL config is NULL, doing nothing
2017-11-19 16:42:27.628 [INFO ] [ternal.serial.CULSerialConfigFactory] - Update config, baudrate = 38400
2017-11-19 16:42:27.631 [INFO ] [ternal.serial.CULSerialConfigFactory] - Update config, parity = NONE (0)

installed intertechno binding and my log says

2019-11-23 14:36:42.026 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model 'intertechno.items'
2019-11-23 14:36:42.052 [WARN ] [echno.internal.CULIntertechnoBinding] - The address parameter is deprecated! Please use just commandOn and commandOff.
2019-11-23 14:36:42.057 [WARN ] [echno.internal.CULIntertechnoBinding] - type=raw;commandOn=01011100110000010111000010010001;commandOff=01011100110000010111000010000001

can someone provide me the correct adress, nothing worked out for me so far.

thank you

ok got it.

  • sudo reboot
  • sudo minicom -o -s
  • serial port setup
  • A - Serial Device: /dev/ttyUSB0
  • B - Lockfile Location: /var/lock
  • E - Bps: 38400 8N1
  • F - Hardware Flow Control: No
  • G - Software Flow Control: No

  • Shift+V (enter) = v1.67 nanoCUL433
  • “X21” (enter) = spoofing on
  • press buttons on remote
    Switch HK_IT01_LED_Printer "LED Drucker (IT)" 			<led_strip> 		(gIntertechno,gLight,OG_Office,OG_Office_Light) 	[ "Switchable" ]
    		{ 	culintertechno="type=raw;commandOn=01011100110000010111000010010000;commandOff=01011100110000010111000010000000"