D-Link Smart Home Binding - DCH-S150

Hi. I am on OH 2.5.0.M3. When I install D-Link Smart Home Binding OH does not recognize my DCH-S150 sensor.
So I tried to add it in dlink.things:

Thing dlinksmarthome:DCH-S150:Sensor [ ipAddress="", pin="270527" ]

But it does not work.
It worked in the past with OH 2.4 so can I install old binding? How?

Ok. 2.4 version into addons directory and it works

Yes this seems to be broken in 2.5. Turning on DEBUG logging gives the following error:

2019-11-18 11:00:51.171 [DEBUG] [home.internal.DLinkHNAPCommunication] - DLinkHNAPCommunication - Internal error
javax.xml.soap.SOAPException: Unable to create message factory for SOAP: Unable to create SAAJ meta-factory: com.sun.xml.internal.messaging.saaj.soap.SAAJMetaFactoryImpl cannot be cast to javax.xml.soap.SAAJMetaFactory
        at javax.xml.soap.MessageFactory.newInstance(MessageFactory.java:120) ~[bundleFile:1.4.0]
        at org.openhab.binding.dlinksmarthome.internal.DLinkHNAPCommunication.<init>(DLinkHNAPCommunication.java:160) [bundleFile:?]
        at org.openhab.binding.dlinksmarthome.internal.motionsensor.DLinkMotionSensorCommunication.<init>(DLinkMotionSensorCommunication.java:154) [bundleFile:?]

I suspect this is as a result of the new build system. @J-N-K do you have any ideas about this problem?

What build number?

This was with M5

@J-N-K have you had chance to take a look at this.

I’m assuming there’s some kind of clash with the saaj-impl 1.5.1 library which is a bundle dependency and the one in java 8, but I’ve no idea how to resolve it.

Opened issue