Danfoss Living Connect Radiator Thermostat Setpoint item problem


(Ole Jeppesen) #1

Hi, i have just implemented some Danfoss Living connect LC13 thermostats with Openhab 1.8.3, and it seems to work OK except for the setpoint item in sitemap.I want to be able to update the temperature in 0.5 deg interval, but regardless how i specify the parameters (with comma or dot separation), i can only opdate whole numbers (intergers). it’s driving me nuts. Any suggestions??

Items file:
/* Danfoss Thermostats*/
Number GF_Kitchen_thermostat_setpoint “Køkken radiator sp [%.1f °C]” (Radiators, GF_Kitchen) { zwave="3:command=thermostat_setpoint,setpoint_type=1,setpoint_scale=0, respond_to_basic=true"
Number GF_Living_thermostat_east_setpoint “Stue radiator_øst sp [%.1f °C]” (Radiators, GF_Living) { zwave="4:command=thermostat_setpoint,setpoint_type=1,setpoint_scale=0, respond_to_basic=true"
Number GF_Living_thermostat_west_setpoint “Stue radiator_vest sp [%.1f °C]” (Radiators, GF_Living) { zwave="5:command=thermostat_setpoint,setpoint_type=1,setpoint_scale=0, respond_to_basic=true"
Number GF_Corridor_thermostat_setpoint “Hall Radiator sp [%.1f °C]” (Radiators, GF_Corridor) { zwave=“6:command=thermostat_setpoint,setpoint_type=1,setpoint_scale=0, respond_to_basic=true”

Sitemap file:
Setpoint item=GF_Kitchen_thermostat_setpoint [label=“Køkken radiator SP”] [icon=""] minValue=8 maxValue=25 step=0,5
Setpoint item=GF_Living_thermostat_east_setpoint [label=“Stue radiator_øst SP”] [icon=""] minValue=8 maxValue=25 step=0,5
Setpoint item=GF_Living_thermostat_west_setpoint [label=“Stue radiator_vest SP”] [icon=""] minValue=8 maxValue=25 step=0,5
Setpoint item=GF_Corridor_thermostat_setpoint [label=“Hall Radiator SP”] [icon=""] minValue=8 maxValue=25 step=0,5

It may be worth mentioning, that comma separation is shown when i get the number from the devices, despite my laptop is using dot as decimal separator.

//Ole


(Rich Koshak) #2

The only thing I have is either:

  • you need to use 0.5 in the step
  • Setpoint only works with whole numbers

You could potentially work around this using a Rule and a Proxy Item.


(krister) #4

Hi Ole
I’m a newbie to openhab and zwave, but, I’m also interested in danfoss living connect integration. How did you do this? Can you please elaborate a bit?

br

Krister


(Ole Jeppesen) #5

Hi Krister.

Do you mean the rounding issue or in general how to define the items for danfoss living?

Brian

Ole


(krister) #6

Hi
I’m interested in the in general solution, how can you define items for danfoss living? Don’t you need to know the commands it sends over zwave?

BR

Krister


(Ole Jeppesen) #7

Hi Krister,

The definitions of the items depends on how you communicate with the zwave devices. What controller do you use? If you use the leave binding in openhab?, then examples are already given on the wiki page.

As I use Vera edge controller, I use the mood binding, meaning that items must be defined different.

So if you can explain your hardware setup I will try to help you.

Ole


(krister) #8

Hi
Thanks, that’s really friendly. I’m a total beginner so, it might be a
daunting task for you. No hard feelings if you give up, but, lets make a
try.

My hardware setup is that i have:

  • A Aeon Labs Z-stick Gen5 USB-adapter
  • that is connected to my Synology DS415+ where I run openHAB.
  • I’m able to find the Danfoss living connect devices when searching for
    "things".
  • I use the Z-wave binding

I have considered to use a respberry or something, but, for now, I use my
synology, since I already got one and it seems to run fine.

Any advice is appreciated!

BR

Krister


(Ole Jeppesen) #9

All right,

Have you defined any items?

I have included two sample items:

Number          GF_Corridor_setpoint 	"Hall SP [%.1f C]" 			<temperature>	(GF_Corridor, Radiators){ channel="zwave:device:a48f8251:node5:thermostat_setpoint_heating" }
Number          GF_Corridor_battery  	"Hall BS [%d %%]"  			<signal>		(GF_Corridor, Radiators){ channel="zwave:device:a48f8251:node5:battery-level" }

The device adress (a48f8251:node5) you can find in Paper UI => Configuration => Things under the specific Zwave device.

That’s all it takes. Hope you can get it working

BR

Ole


(krister) #10

hi
Thanks for the example. It seems like you are configuring your items in files? I have tried this, somewhat successfully. The items appear under Items in the configuraiton section, however, they don’t end up in the Control section, so, I can’t use the item?

I have used “discovery” when setting upp the danfoss living connect as things, do I have to set them up manually in order to link them to items?


(Ole Jeppesen) #11

Yes, i define all my items in the *.items file placed in the openhab config folder. I find that to provide the best overview.

I have newer tried to use Paper UI to create items and link them to channels, so cannot help you here, sorry.

If you go into one of the items in the configuration section what do you see then? How many channels? And are any of the channels linked?


(krister) #12

Hi
The issue I face is that there are no visible channels? But, I’m considering using files since it gives you more control. I also consider trying the “simple mode” where channels and items are said to be automatically linked.

but, anyways…thanks for your help. I think the file way, will work for sure

BR

k


(Ole Jeppesen) #13

Hi,

If there are no visible channels, then something is wrong. Maybe the device is not yet fully configured by the zwave binding?


(krister) #14

hmmm…ok, I C, something stinks here then…ok, I’ll do some investigation on this…


(krister) #15

Finally!
Got it working!
I read some other thread about another issue regarding that discovery didn’t identify the device type. The solution for that case (and mine) was to simply put, trigger the discovery multiple times in a row. When doing that I could see that the node .xml files were created and the device was finally identified as LC-13 Living Connect Thermostats. This made the channels available and I was easily able to create the items and get them into the Control panel!

Thanks Ole, you lead me in the right direction!

BR

Krister


(krister) #16

Hi again Ole!
Sry that I hijacked your thread here, but, I just wanted to let you know that I have managed to solve the problem of setting temperature by 0.5 deegrees. I think it is pretty much as you did it. The only thing I have done so far is to specify my Item as follows:

Number LivingRoom_Temperature “Radiator 1 [%.1f °C]” {channel=“zwave:device:8e22aa81:node4:thermostat_setpoint_heating”}

When having this config I can set the temperature with half degrees from the Control, e.g. 22.5 degrees. This change is also reflected to the radiator unit itself.

BR

K