DarkSky offline, unable to add bridge again

After upgrading from OH2.5 to OH3, I noticed that the DarkSky bridge was offline. The API key is fine, so I tried deleting and re-adding it, but on trying to add the DarkSky account again in MainUI, the screen showing the things available to add never appears (it just keeps flashing endlessly).

The DarkSky API is still working fine when I call it directly.

Any hints?

Correction: I went to lunch, and when I came back the “Dark Sky Account” and forecast thing options had appeared.

Still same result after I reinstall though.

DarkSky was acquired by Apple in 2020. After they completed the acquisition they:

  • killed the Android app with only a couple months warning with a nice “You should upgrade to an Apple” message
  • disabled new sign ups for API keys
  • announced that their public API will be discontinued at the end of 2022 completly

In short, DarkSky is becoming something only the Apple provided app can access.

So you have to decide whether to spend time now trying to make the app work knowing it’ll go away in the near future anyway, or move to a different provider. Right now the OpenWeatherMap API is about the only one we have a binding for that still works and is still free.

I didn’t know about the end of 2022, but that’s still 18 months. I’ll take it for now.

Looking at the logs, I’m putting it down to the general collapse in my OH system, leading to Java heap space error. Upgrading to OH3 has fixed nothing, unfortunately. More on this in another post when I’ve investigated further.

You will probably find that most everyone has moved off of DarkSky and I doubt it’s really maintained any more so there might not be many who can help you any more and if there is a problem with the binding it might not get fixed.

I think it’s fine, actually. The problem is a general problem with my system. Still testing.