Dashboard, paper ui stopped after update to 2.5.3-1

Continuing the discussion from [SOLVED] After update to openhab 2.5 -> Stopped Dashboard?:

If anyone has any hint, it would be very much appreciated!

I had the same issue, i installed with apt.
I removed the openhab2 + openhab2-addons
All my items, rules, bindings (installed with addons.cfg) and things (didn’t disappear)
I then installed openhab2 again using apt.
After 5 minutes everything was working again, and no issues!

Maybe this works for you also, much luck :wink:

1 Like

Thanks @JornHermans for your hint! Can you tell me which files are then deleted if I remove openhab2 and the openhab2-addons? It seems that the addons were not installed after the upgrade…

What about the rules, items, bindings, things and all of the config, this will retain on your HDD? I don’t want to completely kill my installation :grimacing:

edit: I managed at least to get paper ui and habpanel back for a moment; I added the packets = expert and the uis in the addons.cfg but when these were installed, I deleted all lines from the addons.cfg again but it now seems still that the openhab service stops the Paper UI for examle…
2020-03-24 19:43:49.213 [INFO ] [basic.internal.servlet.WebAppServlet] - Stopped Basic UI

Can anyone help that I get a fully running openhab again? I am really unaware of what I did wrong :sob: with the upgrade through the normal means…

edit2: For the history books:
openhab> feature:install openhab-ui-paper in the karaf console gave me back my paper-ui; however if anyone can explain to me why I lost it during the upgrade this would be very much appreciated! Cheers!

edit3: openhab is completely out of control, it is currently uninstalling all of my bindings?!?! What’s going on here??? I’m lost folks :frowning: When I reboot the raspi, it always gives me back the address how can I exit this loop? Thanks in advance!!!

Hi @Klimbim sorry for the late response we had some family emergencies.

First of al when you delete te openhab2 and openhab2-addons it will only delete system files the files you created yourself in the folders under /etc/openhab2/* will remain there and when you do a new install it will use those files so if you configured the addons.cfg file it will also auto install al you’re bindings, ect…
I noticed that after deleting openhab2 and reinstalling it, the things i did create in the paperui also remained. Buth if you want to be really sure i suggest you to make a copy of the /etc/openhab2/* folder, i also did this.

It’s also not needed to install the openhab2-addons packages this for when you would use you setup offline and can directly download any wanted addons from the internet.

To Reply at you first edit:
I think the best way to get it fully working and without these wierd error’s the easist way is to just remove and install it back again. It took me over al 5minutes.

And in Reply to you’re second and 3th edit:
I see that whats happening is quite te same what happend to me, i think there is some issue between the versions, so a reinstall will resolve this.
Also if the address is pointing you to this is normal behavior, but it takes some time for openhab to get fully started and display the page that you are supposed to see there.

So to conclude i strongly suggest to remove and install the openhab2 package all over again, this will most probably resolve you’re issue. Please let us now if this worked for you, so when other users experience this issue they can also try this.

Hey Jorn, thanks a lot for your helpful reply, very much appreciated!

Of course nothing is more important than your beloved ones nowadays…

I did as you proposed:

apt-get remove openhab2-addons
apt-get remove openhab2
apt-get autoclean
apt-get update
apt-get install openhab2

I went to the dashboard and needed to select an option because nothing was installed. I selected expert but afterwards got this error message:

2020-03-25 12:24:52.204 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-transformation-javascript, openhab-transformation-regex, openhab-ui-habpanel, openhab-transformation-jsonpath, openhab-transformation-xpath, openhab-ui-restdocs, openhab-transformation-map, openhab-ui-basic, openhab-ui-classic, openhab-ui-habmin, openhab-transformation-xslt, openhab-transformation-exec, openhab-ui-paper, openhab-transformation-scale': Error restarting bundles:

Nevertheless somehow it installed paper ui and the rest.

But now I have the problem that I can’t find my things, it always says Error: 503 - Service Unavailable and the habpanel is not connecting for whatever reason but I see the tiles that I created only without content; something seems to have gone very wrong here :sob:

Any idea how I can recover from this state? Bindings and actions are installed as they were before without doing anything special…

Hey all, I still get the 504 errors an similar, any idea what I could try to get it working again?

Hi all,

I did an upgrade today, restarted openhab and suddenly items are not displayed anylonger in habpanel and I am having all sorts of problems. I read in the log:

Failed installing ‘openhab-binding-http1, openhab-binding-exec, openhab-binding-digitalstrom, openhab-transformation-javascript, openhab-binding-network, openhab-persistence-influxdb, openhab-transformation-regex, openhab-ui-habpanel, openhab-binding-weatherunderground, openhab-transformation-jsonpath, openhab-binding-mqtt1, openhab-transformation-xpath, openhab-ui-restdocs, openhab-transformation-map, openhab-ui-basic, openhab-ui-classic, openhab-binding-openweathermap, openhab-binding-astro, openhab-ui-habmin, openhab-transformation-xslt, openhab-action-mqtt, openhab-transformation-exec, openhab-ui-paper, openhab-transformation-scale’: Error restarting bundles:

Can someone point me to how I can stop openhab trying to install bindings and such on its own?

Thanks a lot!!!