Daylight Savings Time ignored in OH3?

Openhabian 3.1.0 running in Docker


We’ve just clicked over to Daylight Savings time on the East Coast of Australia and the openHab logs and cron times in scripts are out by an hour. My system clock is set to AEDT and the system is displaying time correctly on the linux console.

docker-compose.yml contains (as well as everything else required to bring up openhab):
- “/etc/localtime:/etc/localtime:ro”
- “/etc/timezone:/etc/timezone:ro”

At the linux console: ‘cat /etc/timezone’ returns ‘Australia/Melbourne’
At the karaf console: ‘env | grep timezone’ returns ‘GMT+10:00’

I tried removing the timezone setting in the OH3 GUI and restarting, but it still returns ‘GMT+10:00’ in the karaf console.

Have I missed something in configuring timezones in OH somewhere? I have gone through the forums and couldn’t find anything relevant. Hoping someone can nudge me in the right direction. Thank you.

I think you need to check/set locale in a third place, the Java environment.
The logging and cron scheduler are working off the Java clock, which may be different to openHABs, and different to the host OS.

Some of the Oz zones have DST and some don’t, if I recall?

@rossko57 , thanks for the pointer. Yes, Australia has a mix of timezones that do and don’t enact daylight savings. The post you provided a link to has the answer that fixed the issue. I added the below environment setting into the docker-compose.yml under ‘openhab:’, and restarted the container - log timestamps fixed, and assuming from other posts, cron driven rules will be fixed too. I will confirm that tomorrow after a couple of things should fire off in the morning. Thank you again.

    - EXTRA_JAVA_OPTS=-Duser.timezone=Australia/Melbourne