Deactivate automatic Grafana update during openHAB reboot

I installed openHAB on an existing older Raspberry.
The problem then started with Grafana. The last Grafana that runs on the old hardware is 5.1.4.
Now, during the reboot of openHAB, it has updated to Grafana 7.0.0 and the service no longer starts. After downgrading to 5.1.4, everything is chic again.
Now I have searched a little but found nothing: How can I deaktivate this automatic update when restarting?
My openHAB now always reports on SSH login that the installation is incomplete …
regards, Tobias

More precision in reporting, please.
I assume you mean you run openHABian ? Version ? HW ?
A fix is in the works, so just wait another day.

Thank you,
I use openhabian on a raspberry pi1 and in

is written, a newer Grafana don’t funkition of armv6.

my version of linux:
uname -a
Linux openhab 4.19.97+ #1294 Thu Jan 30 13:10:54 GMT 2020 armv6l GNU/Linux

On a RPi 1 with just half a GB - serious ?
Running Grafana there is not supported by openHABian… it tells you when you try to install from openhabian-config, doesn’t it ?
But you nonetheless insisted on installing and now that it does not work you want us to help with that ?
Sorry but no that’s nothing I’m willing to help with :roll_eyes:. openHABian tests efforts are huge and hints are there for a reason.

openHABian doesn’t update packages on reboot. Your problem is that your installation failed and you’re in a half-baked state now. That has nothing to do with Grafana. So fix that first or start over.

I did not see that, please give a pointer.

And move to newer HW or at least omit Grafana.

thank you,
you are right - I should use new hardware.

It was just a test - then it grew and it worked.

Grafana was installed without errors - but the service did not start - only after the Dowmgrade. Then grafana surprisingly worked.

The installation error only came after a later restart. The Grafana update was installed. So I suspected it was because of it.

Now I have downloaded the rpi version für armV6 directly from Grafana:
I didn’t know there was this version.

Now the system also works after reboot, it only appears in the firstboot.log
2020-05-28_18: 47: 24_CEST [openHABian] Updating repositories and upgrading installed packages … FAILED
2020-05-28_19: 12: 45_CEST [openHABian] Initial setup exiting with an error!

I know, I can’t get support for that … :wink: