Deconz: lights flash when dimming from 0

I switched my lights from the hue bridge to deconz.

I did not touch the configuration of these lights, other than moving them to the deconz virtual hue bridge in openhab.

Everything works as expected, but one thing does not:

if i dim up my innr lights for example by a slider in a sitemap or a rule, the lightstrips instantly go to the set value, then back to off and then they are dimming up to the set value. So they first flash and then dim up. It does not happen if i control them from deconz directly, and if i just turn them on from openhab, they go to the last setting instantly.

I could not find any solution, does anyone have any hints?
Thanks :slight_smile:

1 Like

Hi @openhabber,

You might want to enable TRACE logging for the Hue binding to get an idea of what interaction is happening between OH and deCONZ REST API.

hello @cweitkamp,

thanks for your answer.
there is only one request going to the virtual hue bridge of deconz:

2019-10-13 23:15:21.990 [DEBUG] [nhab.binding.hue.internal.HttpClient] - Async sending put to address: http://localhost:5100/api/A697051788/lights/15/state delay: 120 body: {"on":true,"bri":170,"transitiontime":4}

i even tried putting that request to deconz directly, with a REST client, same behaviour. Does this mean that it is deconz fault, or is something not right with that command?

any idea why that could happen? Should I ask at the deconz forums?

EDIT: i played around a little, if i do transition to 0, they go on without flickering. If I make transitiontime bigger, it flickers and dims up slower afterwards.

Currently I have the slight feeling that it could be a deCONZ related issue. From my point of view it will not hurt to ask for help over there too.

I do not own a lightstrip but some colored bulbs and still have an open item on my to-do list to test the fadingLightCommand action provided by the Hue binding. I will report back once I will have tested it.

I asked for help there, but i did not get an answer yet.

I found the fadinglight action in the binding documentation and am using that in my rules, if the strips are the target, and it works by setting the time to 0. They go on faster that way but dont

Would be nice to set the default fading time as an optional parameter of the things, maybe to set it slow for some color lights so they always have a nice effect while switching or so.

Either way, im hoping i get some answer from deconz, i opened an issue there:

I will keep you updated if anything happens.

I had similar behavior with hue lights and it was related to the alert & effect channels. When one of them had gotten a value other than NONE in the past my lights flashed when I switch them on.
Took me some time to see that connection, but after I made sure that I had send NONE to these channels the problem was gone.
Could your problem be related to that? :thinking:

Thanks for your input.

I can only select “STOP”, i cannot send NONE… it did not change anything. It looks like this:

So did selecting ‘STOP’ help?

Sadly, it did not… :confused: