Deconz: Stuck with Aqara sensors and 2.5.0 snapshot

I know, neither manual or auto works just config file apparently.
Mine survived from the snapshot I was on when it worked. All came online again after the Bridge came online.

Edit: when the snapshots are working again (my system constantly hogged 100% CPU), much is probably fixed.

@maxheartrate I saw your issue on GitHub and was just wondering if your are still facing the same problems. Or did you install a new snapshot version in the meantime?

I think I am using nearly the same sensors like you and they working fine for me. Even the discovery is working with the latest version.

Hi Christoph,

thank you for asking. Most of it works now when I disable and reenable the Deconz thing in Paper UI. Since I use text configuration files I did not look into the Paper UI.

The remaining problems are:

  • I cannot get the Aqara Vibration sensor to work in OpenHAB.
  • The motion sensor often doesn‘t work (light is not switched on via OpenHAB).

Do you have vibration sensors in your setup?

Regards, Max

Unfortunately I neither use Aqara vibration sensors nor Aqara motion sensors. IIRC one of my colleagues uses them. I will ask him for help. My Hue and TRÅDFRI motion sensor work like a charm.

May I ask you again to tell me your current binding version? Thanks.

Hi, my software version for the Deconz binding is 2.5.64.

@maxheartrate Sry for my late response. Is this still an issue for you? Did you update deCONZ or / and openHAB in the meantime?

Hi, no problem. I am still on the same version.

Both sensors are working with the latest version. But I can’t get the batterylevel for the temperature sensors (REST is showing it).

I have batterylevel for my aqara temperature sensors. It did not show up immediately, but after waiting some hours/days(?).

Yes, its working stable since the next day!

@frest can you post the things and items file that worked for you? I am having some trouble with the motion sensor. It appears I get battery level and temp but I can’t seem to get the correct combination to retrieve the rest.
I am on 2.5m6.

Looks like I got it figured out. Seems to be working. For some reason I had to restart for the values to show.

presencesensor    LaundryPresence      "Laundry Room Presence"           [ id="9"]// motion sensor part
lightsensor    LaundryLux      "Laundry Room Presence"           [ id="10"]  
Number:Temperature Temp_Laundry "Laundry Sensor Temp [%.1f °C]" <temperature> (gSensors)  {channel="deconz:presencesensor:homeserver:LaundryPresence:temperature" }
Switch MotionLaundry "Laundry Motion Sensor" (gSensors) {channel="deconz:presencesensor:homeserver:LaundryPresence:presence"}
Number BatteryLevel_Laundry "Laundry Sensor Battery Level [%s %%]" <battery> (gSensors,gBattery)  {channel="deconz:presencesensor:homeserver:LaundryPresence:battery_level" }
Switch BatteryLow_Laundry "Laundry Sensor Battery" <selfbell> (gSensors,gWarning) {channel="deconz:lightsensor:homeserver:LaundryLux:battery_low" }

Number:Illuminance LuxLaundry "Light Level Laundry" <light> (gSensors) { channel="deconz:lightsensor:homeserver:LaundryLux:lightlux" }
Switch LaundryLightOff "Laundry Light Off" (gSensors) {channel="deconz:lightsensor:homeserver:LaundryLux:dark"}

Xiaomi smart plug (zigbee) doesn’t work with Conbee 2 in OH, no on/off (switch) channel in OH. Version 2.5 M4 and RBpi 3+. (It works well in Phoscon app).
It will work with M5 or M6? If not, please fix it.