Delete rrd4j files: Permission denied

Hi,
I would like to delete some rrd4j files which are located in the persistence folder.
Now I don’t have access with my sudo user.

/var/lib/openhab$ cd persistence/
-bash: cd: persistence/: Permission denied

owner of the folder:

/var/lib/openhab$ ls -ld persistence/
drwxr-x--- 5 openhab openhab 4096 Aug  2  2021 persistence/

Does anyone know how I delete these files?
Thanks, BR

runtimeInfo:
version: 3.4.0.M1
buildString: Milestone Build
locale: de-DE
systemInfo:
configFolder: /etc/openhab
userdataFolder: /var/lib/openhab
logFolder: /var/log/openhab
javaVersion: 11.0.11
javaVendor: Azul Systems, Inc.
javaVendorVersion: Zulu11.48+21-CA
osName: Linux
osVersion: 5.10.123-meson64
osArchitecture: aarch64
availableProcessors: 4
freeMemory: 149042600
totalMemory: 524288000
startLevel: 100

What is the name of the user that you used when you tried to cd into the persistence folder ?
It has to be user openhab or a user that belongs to the group openhab. root will be able, too.
It looks like none of these criteria is fulfilled.

What you can do is to get a root shell:

sudo bash

then cd into that directory.
To delete the files I first would stop the openhab service. In case ZRAM is enabled also stop that one first.

That did the trick.
I tried it with my root user and I was thinking with this user I automatically have all rights.