Deleting Items in Paper UI results in Error 404

Hello folks,

I am facing an issue with my openHAB2 instance ( openHAB 2.0 Build #629)

In the Paper UI I can see 2 items I added recently but should be removed. It seems that they were removed becaused I cannot find any trace of them in any file but they are still shown in the Paper UI. When trying to delete them I get the error message “Error 404 - Not Found”.


Does anyone have an idea how to get rid of these 2 items in the Paper UI?

I have the same problem. The Solution ist straight forward.
1.) Stop openhab2,
2.) Edit the jsonDB Files with a text editor.
3.) Start openhab again.


1 Like

Cool. Thanks, Can you let me know where these files can be found?

You can find the files at /var/lib/openhab2/jsondb.

Perfect! Worked for me. Thanks for your support.

I had the same thing, and it occured to me when I deleted a parent without the children items.

This is gross. It’s been ~5 more months, the “2.0 release” has been out for a while, and you still can’t delete items from the UI… this should be the simplest action to implement. I don’t get how progress is coming along so poorly on a lot of this stuff. It is not “straightforward” to stop and restart openhab2 when it takes at least 15 minutes for the zwave heal to happen when it starts up. Sigh.

1 Like

I think I had the same problem and could solve it without restarting: Went to “Configuration -> Items” in the paper UI and clicked on the delete icons of each item. Wondered why they weren’t removed. Clicked again and got “404 not found” notifications. Then I went to “Configuration -> Things” and saw that my Things were still linked to the Items. Removed the item from each channel and voila - the items were gone!

I poked around in the issue tracker and found this issue: That probably means that not deleting stuff “on both ends” was a deliberate, albeit misguided decision which will be rectified in the future.

The problem is still there in the OPENHAB 2.2 Snapshot…

And still causing considerable hassle.
I tend to leave the old rubbish in there as It takes too much time and disruption to keep restarting OH2. A 10 to 15 minute exercise to delete some items after going through the exercise to delete already in a GUI is not acceptable to experience me.

I think there is an easier way to delete items from PaperUI (because I had the same problem)

Generally - I know that it is possible to remove items via PaperUI (and without changing something in some database) - because I have done it and it had worked.

As far as I remember you need to do the following:

Go (in PaperUI) to "Configuration/Things) and click on the channel of the item that you want to remove.
On the right side you can see a little wastebin-symbol.Click on that.

Afterwards it should be possible to delete the item (in Configuration/items)
When you have removed all items which are linked to a Thing than you also can delete the thing.

1 Like

I have been unable to find a way to delete 4 duplicate items. The duplicates show up in PaperUI when the simple mode is turned off, but when I try to delete them I get an Error 404. I have tried deleting in Habmin without success. I have also tried I’ve tried going to the files in /var/lib/openhab2/jsonDB and deleting the reference to the duplicate items, but that just disabled the items all together (the items in the default sitemap stopped working). I’ve tried deleting the cache files in /var/lib/openhab2/cache without luck. I have run out of ideas and can’t find any new suggestion in the community. I am ready to give up and live with it. Openhab just doesn’t want to give up these items it seams.

I seem to have solved the problem, at least for the time being. I went into my items file and renamed all the duplicate items, adding an “A” at the end. I then updated my default sitemap with the new names. Once done I went into the PaperUI and all the duplicate items were gone, and no more entries in the log. So far so good.

I spoke too soon. After a restart all the duplicate items are back. However since I renamed the items in my .items file Openhab is not complaining anymore. Still, I would like to delete these things once and for all. When I try now I get a 405 error - Method not allowed.

9 months later, but the error is still the same…

I just started with two fibaro dimmer 2 for a test run and ended up with a log full of errors after a few minutes…

It seems that it still does not work to delete a simple item…