Denon AVR4308 and OH 1.7, can get status but commands are ignored

Something that’s been bothering me a lot with my Denon AVR 4308: The binding seems to works, OpenHab initializes OK without errors, I get status update from the AVR but it won’t accept any commands. The weird thing is that I can see OpenHab displaying that the commands were sent to the AVR, but there is no response to power on, power off (Standby) or mute switch toggles. Telnet works, and I can also control the AVR with the Android version of AVR-Remote.

I know that the 4308 can only accept one Telnet instance but I’m careful to switch it on and off before I try any new connection, for some reasons the communication with OpenHab is one way only.

I also tried to change from telnet to http but got flooded with error messages once the AVR and OpenHab were restarted.

Any idea how to steer me in the correct direction to solve this problem?

Update: I did upgrade to 1.8 but the binding behavior remains the same:

It loads without errors, OH displays that commands are sent to the AVR-4308
Nothing happens when I select power on/off, mute or zone on/off. The receiver doesn’t execute any command and OH doesn’t display any error. I tried both telnet and HTTP update methods with the same lack of result.

Either there is something very specific with the way OH Denon bindings works on a Windows machine or I’m missing something very basic there. The receiver does work very well with the AVR-Remote Android application so I know that the problem isn’t with my receiver.

Have you find any solution? My reciver is AVR3808!

Unfortunately no. The situation where the receivers and bindings seems to behave like a black hole remains the same.

No errors received on the OpenHab server console and the Denon keep ignoring every single command I tried to send.

I’ve no idea if it’s the same as the serial command setup, but hard power off the amp then power it up again (not using the standby function) and it might start responding

Except that unfortunately it doesn’t. I already tried several time to do a hard power on/off before starting the OpenHab server but that didn’t help at all. The same black hole syndrome was experienced each time and it didn’t really matter if the update was set to telnet or http. Using the same on/off switching strategy, the receiver does respond to commands sent by AVR-Remote, an Android app, so I can conclude that the receiver is fine and that the network connection is working . My interim conclusion is that older Denon receivers, such as the AVR-4308/3808, are not supported by the Denon binding and that this should be documented in the binding Wiki.

What is in your config file for the Denon Binding?
What is your sitemap and items content for the Denon Controls?

If you are getting feedback but not having commands actioned then the binding should work fine… The issue older Denons had was that they wouldnt give feedback but would take commands, so I dont think your amp is a special case where it wont action commands.

I hope that there is nothing extraordinary wrong with my configuration. anyway,

my openhab.cfg:

my items.cfg:
/* Denon AVR */
Switch DenonPower “Power” (LVAV) { denon=“avr2000#PW” }
Switch DenonMainZone “Main Zone” (LVAV) { denon=“avr2000#ZM” }
Dimmer DenonVolume “Volume [%.1f]” (LVAV) { denon=“avr2000#MV” }
Switch DenonMute “Mute” (LVAV) { denon=“avr2000#MU” }

my sitemap:
Group label=“Denon AVR-4308” {
Switch item=DenonPower
Switch item=DenonMute
Switch item=DenonVolume
Switch item=DenonMainZone
Switch item=DenonSurroundMode

I’ve read a few hints that hint at using http and restart the openhab instance to force the changes through.

It’s fairly common for the older amps to not provide feedback, but all seem to take commands.
I guess a really annoying fallback could be to do it via rs232…

Where can we ask to add support for older networked Denon recivers?


I also have a 4308. I can control it with ‘Deremote’ app for Ipad (with feedback). However the Denon binding doesn’t seem to be compatible. Can we adapt the binding to make it backwards compatible?



Try to help here!