Denon Binding Volume Dimmer?

Anybody have the Volume Dimmer(s) working with the Denon Binding? I have (most) everything else working on my new receiver (an x3300w) but can’t quite get the Volume to work for the Main Zone or Zone2.

The wiki reports the command for Main Zone volume as MV and the Zone2 Volume as Z2ZV. Using MV and the %.1f reports the correct volume level (which is in and of itself amazing:)) but hitting the up arrow takes it to 100 and the down arrow to 0. The volume on the AVR doesn’t actually change with the buttons, just the number reported. If I hit volume up or down on the physical remote, openHAB goes back to reporting the correct volume level. The Z2ZV command only reports 0.0 and changes to 100 when the up arrow is pressed, but on the actual unit Zone2 is turned ON. For the Zone 2 Volume item, Up Arrow = Zone2 ON, and the Down Arrow = Zone2 OFF.

Looking at the protocol documentation for my unit ([here])( which apparently applies to most models, it appears that, though MV is the listed command for Main Zone Volume, the command(s) for Zone2 (or rather Zone#) volume is the same 2 character prefix as Zone2 Power (Z2). That is the documentation’s listed command for Zone2 Power is Z2ON and Z2OFF and for Zone2 Volume is Z2UP and Z2DOWN. This certainly would explain why the arrow keys on the Zone2 Volume commands is turning that Zone ON and OFF, but I’m really not sure how to fix it.

Obviously this would be an excellent opportunity to learn some coding and fix the binding, so I had a look at the code on github and was very quickly dissuaded of that notion :blush: I am no where near knowledgeable enough to even follow the code, much less fix it. I’ll keep at it, but if there’s a more efficient way to bring up these issues I’d love to hear it. I’m also ignorant about the protocol here, it looks like the binding hasn’t been touched in 7 months, so nothing will probably get done, but if there’s any advice anybody has on how to help fix this, I’m all ears:)

Found the same problem here when I moved openHab to new NUC system in my LR. The problem is between the binding and the default web UI slider control for a Dimmer item. If I revert back to openHAB 1.8.1, it works fine. Anything beyond that, no joy. So for now I’m going back to 1.8.1, if I get a chance (I have on lot on my holiday TODO list!), I’ll try to debug what’s going on…

Well, it’s not just the Denon. Sliders are apparently completely DOA in 1.8.x, the answer is to “move to 2.0”. I had a rough experience trying that before, not sure if I feel up to it right now.

@DDDorsett Why do you say its not just Denon? It seems like the Denon binding is bungling which its sending to the slider, not just the implementation of the slider? I had issues with sliders in 1.8.0 and the default WebUI that was fixed when updating everything to 1.8.1, but I’m curious if you’re right and this is the issue again (I may have apt-get updated to 1.8.2…).

in a more generic sense, the issue I brought up with the command for Z2 Volume having the same prefix as Z2 Power (Z2ON/Z2OFF vs Z2UP/Z2DOWN) seems to be an issue that isn’t addressed in the writing of the binding, but I could be wrong…

I did find this in Github for the binding:

    // Matches all secondary zone commands with a parameter. Example: Z2TUNER
    private static final Pattern ZONE_SUBCOMMAND_PATTERN = Pattern

Which, contrary to what I thought, seems to be accurate (though I’m far from a regex expert). I’m not sure how you label the command. Is it Z2 for power and Z2ZV like the wiki says? I feel like I had this working before, but can’t be sure now. Are we all of the opinion that this is actually a slider issue? and that it won’t be fixed unless we downgrade to 1.8.1 or upgrade to 2.0?

I was wondering if you’re willing to share your X3300W protocol list/doc? I’ve got the same receiver.

Thanks in advance.