Designer not displaying items (designer on windows, openhab on linux)


I use designer from my windows laptop, with openhab deployed on a linux box. I use samba / windows share to access the configuration folder, the .items and other files etc open / edit just fine however items are not populated in the items window.

Is there some other configuration step needed ?


Two things to watch out for:

  1. in case you have changed any samba setting while still or auto-connected to the Linux share via Windows explorer, open a dos prompt and type:
    net use \<linux_host_name> /delete
    … and log into the Linux share again

  2. I had a similar problem the other day with designer on Windows, and it was suggested to delete in re-install the drive:openhab directory. This fixed the problem.
    he designer creates a few file and directories after its first start, and in case you open the designer twice or force-kill it one or more files get corrupt and cause all sorts of weird errors.

Good luck :slight_smile:

Re-install solved the issue, thanks !!

I am glad it worked out; feel free to give my post a tick for the ‘solution’ to your problem.

done. Can you please also advise on couple of related items:-

  1. Autocomplete on “.” How can this behaviour he enabled, as of now have to explicitly press ctrl+space.
  2. Additional Menu items like save, rename etc - these don’t appear as in normal eclipse, can preferences be changed? if yes, how ?
  3. Drag and drop from item window to sitemap or rules files - doesn’t work for me, is it supported ?

Hate to phrase it this way, but you really really don’t want auto complete on . . I’ve had times when it takes ten seconds for the auto complete list to populate because there were so many options. Doing this all the time would drop designer’s usability dramatically.