Designer on Windows 10: unable to instantiate class

I installed designer on Windows 10.
Worked to the point that I could see config files, and open them.
However, under the file menu there is no “Save File” or “Save As” option.
I closed the designer and reopened it, and it came up with the following error:
Plug-in “org.openhab.designer.ui” was unable to instantiate class “org.openhab.designer.ui.internal.views.ConfigNavigator”.

I read through the forum and did not find anythign elated to it.

I am running the 32-bit Java Platform Se binary 32-bit. It it working as the Arduino IDE is using the same Java platform.

Three full days in openHAB and only problems :frowning:

I had it up and running in six hours one year ago …

Clearly indicates you must be smarter than me :smile:
I have done Linux occasionally, hence, a lot of things are not understood, such as ownership, why a user openhab, can I own the files.

So, any idea why the designer throws an error?
Any alternatives working the config files?

No. Maybe you have to reinstall it?

Yes, you could use the openHAB 2 Designer:
http://www.eclipse.org/smarthome/documentation/community/downloads.html

Definitely not :grinning:

But: I’ve never used the demo, just for reference purposes (“How does a timer work?”).
And before I tried something to setup, I read the wiki, it helps in most cases.

Have fun.

1 Like

Have you tried to ‘right-click’ on your mouse when editing a file. This will reveal a number of options for saving etc…(at least for openHAB 2 designer anyway)

1 Like

@sihui: that did it! – The re-installed.
I noticed when I launched it that it creates the odd file and directory, which may have gotten corrupted on exit.
You are a life-saver! Thanks again!

@MikeD: Thanks… strange as it seems, the right-click menu has these option.
However, I would have expected these under the File menu as well :sunglasses: