Detached nodes in ZWave Network viewer

No luck unfortunately. :frowning:

They are still detached.

I am trying to avoid yet another reformat of the rpi and setting everything
up from scratch…
Or even worse - trashing the config on the usb stick and readding all
devices, but seems I might have to do that.

2017-07-02 14:01:37 +0000 SiHui :

I’m pretty sure that is not necessary.

Did you already try deleting the things and adding them back? In a lot of cases this works.
After deleting the thing, also delete the xml (make a backup) and let them recreate during initialization.

Nope, but that’s the next thing on my list of todo things.

Backup first, then deleting them and checking. Let’s hope that’ll work :slight_smile:

Thanks for the tips so far!

2017-07-02 14:40:32 +0000 SiHui :

I believe the security branch has a fix for this. Discussions are underway to determine when it will be merged into the snapshot builds.

@sihui - no luck. Deleting nodes didn’t help. Still after a reboot the nodes are gone.
And this only happens to battery operated nodes. This is… annoying :slight_smile:
I do hope there will be a patch release to fix this problem and we won’t have to wait for 2.2 :persevere:

I don’t think a patch is needed because my Danfoss is working fine. It was working with openHAB1, it was working with openHAB2 snapshot and it is currently working with the development binding.
I can’t remember any user reporting this issue.

Maybe you should

take that advice and switch to the development branch. The breaking change with deleting nodes and recreating for that binding version to make it work again has to be done anyway, so why not give it a try:

@sihui - right. Let’s compare our setups.

I’m using a raspberry pi 3 with openhabian (downloaded and installed it fresh last night) with the Aeon ZStick GEN5.

I switched to the development build of 2.2 - no dice.
I installed openhab from scratch, removed devices from the ZStick - no dice. After a reboot, all battery operated devices are no longer accessible or visible in Openhab.

The ONLY thing that I changed recently - to make this problem appear) was to switch to 2.1.

I’m trying to figure out what might have happened.

I mean… We’re talking an installation that worked flawlessly for over a year - first in 1.8, then in 2.0 (I believe I also tried one of the RCs). Same day I installed 2.1 and wanted to make a full image backup of the SDcard - on reboot - devices no longer available.

6 hours later - I reset everything. All devices are reset to factory defaults, same with the ZStick.
I flashed Openhabian from scratch again.

And we’re back to the same behavior.

A reboot of OpenHab causes all battery operated devices to no longer work and I get:

19:45:17.789 [WARN ] [ssage.ApplicationCommandMessageClass] - NODE 3: Not initialized yet, ignoring message.
19:45:17.861 [WARN ] [ssage.ApplicationCommandMessageClass] - NODE 3: Not initialized yet, ignoring message.
19:45:17.942 [WARN ] [ssage.ApplicationCommandMessageClass] - NODE 3: Not initialized yet, ignoring message.
19:45:18.001 [WARN ] [ssage.ApplicationCommandMessageClass] - NODE 3: Not initialized yet, ignoring message.

in the log for each battery operated device.

Switching to 2.2 development branch does not fix it.

But… switching to Domoticz (which I really do not like) - solved all problems while working with Domoticz. There, each device shows up properly and gets refreshed on each wake up.

So I did another test and this time, when Openhab booted up, this is what I saw:

19:56:31.387 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 1: Node found
19:56:31.390 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 7: Node found
19:56:31.392 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 8: Node found
19:56:31.394 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 9: Node found
19:56:31.397 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 10: Node found
19:56:31.400 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 11: Node found
19:56:31.402 [INFO ] [age.SerialApiGetInitDataMessageClass] - NODE 12: Node found
19:56:31.405 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller using Controller API
19:56:31.408 [INFO ] [age.SerialApiGetInitDataMessageClass] - ZWave Controller is Primary Controller
19:56:31.410 [INFO ] [age.SerialApiGetInitDataMessageClass] - ------------Number of Nodes Found Registered to ZWave Controller------------
19:56:31.413 [INFO ] [age.SerialApiGetInitDataMessageClass] - # Nodes = 7
19:56:31.416 [INFO ] [age.SerialApiGetInitDataMessageClass] - ----------------------------------------------------------------------------

Nodes 2 to 6 are missing from the list - they are the 5 LC-13 thermostats I had paired with the ZStick.
I know I did not remove them manually.

When I ran Domoticz again - it also showed that the devices were indeed gone from the list. Waking the thermostats manually and changing their temperature did not readd the devices to the ZStick. I had to restore a backup of the stick to get the devices back on the list.

2.2 snapshot does not have the development binding, it has the snapshot binding. If you want the dev binding you have to install it manually:

That is pretty normal after a reboot: it takes some time until battery operated devices get initialized again. Either you wake them up or you have to wait until the wakeup time has passed (you can set the wakeup interval for most devices through HABmin.)

I guess you did not include them properly. Otherwise I have no idea anymore, I can only tell that the Danfoss I have worked fine with all openHAB and zwave versions since 1.7 (sorry)

I have the same problem with one device, it’s a Vision ZD2102.
With 2.0 I didn’t have this problem, but with 2.1.

When I have a look with HABmin at the device properties, it looks a bit strange and the xml-files differ a lot. See attached files:
20_node13.xml (8.3 KB)
21_node13.xml (8.1 KB)

I tried several times to get rid of it, but even waiting some days didn’t heal the device.

The trouble was that I did wake the devices and gave it even enough time to have them wake up a couple times on their own - that did not help (the same test with Domoticz had devices get rediscovered properly as mentioned above).

@sihui - main question still remains - we must have had a different setup - are you using openhabian? Or a manual install?

@usambara - I finally got it to work. What I ended up doing was a complete reformat of the system on the RPi, but this time - I did everything from scratch and manually without using openhabian. So manually download the image of raspbian and install each package manually. Now I can reboot the device at will and battery operated devices are no longer deleted from the ZStick and show up as online in Openhab. Upon their wake up - they properly repopulate their values.

No, manual install, not apt-repo.

openHABian is nothing else than Raspbian with some additional scripts for ease of operation.
I don’t think your problem was caused through openHABian …

That can’t be the solution…
If you could solve it by reinstalling it means for me that there is somewhere a configuration issue.
Before I have deleted only the configuration and rebuilt it. I think I’ll exclude and re-include it with the z-way-server. Let’s see what will happen.

Btw. I’m not using openhabian but raspbian (stretch).

The thing with me was that I was reinstalling and reflashing about 5 or 6
times, looking for sources of the problem.
Each time - there was a problem. Now I’m on day 3 and everything just works
(manual install).

My guess with openhabian wa smore about the libs that the script installs.
Maybe something conflicted out? It’s also installing OpenJDK by default and
I had to swtich to Oracle Java manually each time. I doubt this was the
problem, but who knows at this point…

2017-07-12 18:38:00 +0000 Ulrich :

Actually I can’t believe that, @ThomDietrich, any thoughts about that?

Neither can I. I’m jumping at straws here.

Don’t get me wrong - I’m incredibly grateful for all the work done by the
team and in awe of how they do it all.

But at the same time, it’s just funny how through multiple installations -
the problem persisted. What really bugged me was how the devices would be
deleted from the ZStick - that had my mind boggled.

2017-07-12 20:45:02 +0000 SiHui :

Excluding them from the network deletes them from the stick.
It only gets problematic when you have a defective device, because you can’t exclude them from the network because they are “dead node”. But there are tools for that case too …

Right, but I did not exclude them myself.

Look at how this looks from my perspective.

For 2 years, the ZStick works without any problems at all. At first, I was
using Domoticz (didn’t like it much), then switched to OpenHab 1.8, then to
2.0RC and then 2.0 Release.

At some point, I even had the infamous SD Card corruption problem on my rPi

  • and still - multiple reinstalls, replacement of the sd card and rPi -
    still - devices would come up instantly after reformat/reinstall/reboot.

Then, one day - a day after I install 2.1 - I want to make a fresh image
backup - boot the rPi back up - devices are shown offline and no longer in
the network. When I wake them manually, OH log shows devices are not in the
network and messages are ignored.

I thought, maybe I screwed up the install, or something - try a new sd
card, new install - problem persists. I reformat a couple times more,
factory reset all devices - problem persists in Openhab, but Domoticz
installed on the same device, same installation of the system - boots up
without a problem, and properly discovers the devices when they wake up.

I get that it’s all probably a major coincidence that problems appeared
after installing 2.1 and kept persisting until I installed everything
manually, but damn if it doesn’t look weird.

There’s one other option - nobody here has control (or I don’t think they
do) over what libs and what versions get installed by third party apps
(like Java, python, Grafana, Influx, etc). Is it not possible that there
was a conflict there that just happened to impact what openhab was doing? I
can’t remember the exact thread here, but then there’s also the question of
OpenJDK. It is known that some things just won’t work with it (like
notifications didn’t work for me the first time I tried it, but started
working immediately after installing Oracle Java).

I’m probably a one off here, so it’s not worth the time to troubleshoot
until someone else reports this, but I had to check if someone else might
have had the same problem I did.

2017-07-13 09:03:55 +0000 SiHui :

Yes, definitely :smile:

But you did

After resetting a device it is excluded from the controller as far as I know

Also have in mind that deleting a Thing does not mean exclude a device from the stick.

Can’t remember reading anything like this, but maybe someone will respond who had similar issues.

Anyway, as long as it works now you might have more luck for the future :thumbsup: