Device configuration, Z-Wave binding database issue


Im trying to add to my z-wave network a HKZW-FLD01 sensor (Hank Flood Sensor). I’ve checked that this device is in the Z-Wave Binding database, but when I try to configure it the device appears like “Unknown Device”.
In HABmin I can see that the flood sensor has sent his information to OpenHAB, but the manufacturer ID that corresponds to Hank (0208) isn’t recognized, so it shows like “Unknown Manufacturer” and don’t allow me to use the device:


How can I solve this issue?


You need to add your device type and device id to the database entry:

Here is a tutorial how to do it:

If you don’t want to do that by yourself (although you should! :grinning: ), check your manual and verify that all configuration parameters, association groups and channels are the same with the existing entry for device type 0201/device id 000F. Then post back your answer and I’m pretty sure one with access to the database will add your type/id 0200:000F.


I’ve added to the existing database entry the type/id 0200:000F, and now i don’t know what is the next step.

The device attributes in HABmin keeps showing “Unknown manufacturer”, as you can see in this image:

I’m just a begginer and I don’t have the knowledges to solve this by myself, so please let me know how to proced.

Thank you in advance.

1 Like

Good job!

You need to watch the “Last exported” date at the end of the database entry. As soon as you see a recent date the changes get merged into the zwave binding.
Then you need to update to the latest snapshot zwave binding or as an alternative to the latest zwave development version of the zwave binding.

Well, the Last Exported date of the entry has just actualized:

I checked that I have the 2.3.0 snapshot of zwave binding installed, so if I update the binding, wouldn’t it be the same version?

Anyway, I don’t know how to update to the lastest snapshot.

No, the snapshot is normally build every day.
The current release date for the binding is 14.05.2018 14:54:29 (see link above), so the export for 14.05.2018 16:04:09 has not been implemented yet. You need to wait until the next snapshot build.

It depends on your installation: if you installed the binding through PaperUI or HABmin, you just need to uninstall the binding, wait a couple of seconds, install the binding.
If you have the zwave binding installed through your addons folder, you need to download the newest jar and drop it into your addons folder, overwriting the old one. Then restart openHAB.

I updated to the lastest zwave binding which includes the last export of the device. Unfortunately, OpenHAB still not recognizing the Flood Sensor.

I am really thinking that there is an issue with the manufacturer. It shows “Unknown manufacturer”, so the device type/id can’t be linked to the database entry associated with Hank manufacturer.

I’ve also seen that in the manufacturer list there is an entry that associates the code 0208 with the manufacturer Hank, so I don’t know why keeps showing “Unknown manufacturer”.


I need to solve this as soon as possible, because the device must be working to finish my final career project in a few weeks.

It might be the latest export, but it doesn’t include the changes that you made recently. The latest export is from 5 months ago (December)…

I have not had the chance to do a database update since you provided the data. I normally do this once or twice a week and I’ll likely do another update tomorrow or Friday.

I’ve just seen that you have updated the database today.
Tried uninstalling and reinstalling the Z-Wave binding in Paper UI, but the device still not working. Shows like unknown device and unknow manufacturer.
How can I solve this if I actually added the devide type/id to the database and it didn’t worked?

Are you running the snapshot version of the runtime, or the release version? If you are running the release version, then you will always install the same version.

Hi Pablo,

Did you finaly get the Hank Flood Sensor working? I bought one a few months go and couldn’t get it to work neither? I bought myself another one from another manufacturer(Everspring) No, a couple of months later I trying to get the Hank sensor working but stil, again the same problem: Unknown manufacturer.

I know the sensor works in Domoticz. If I don’t get it to work I’m considering migrating to domoticz.

What are you experiences so far?


It probably won’t work with the release version of openHAB (2.4), you need to upgrade to the latest zwave 2.5 snapshot binding.
Please provide the xml from your userdata/zwave folder so we can double check if the device is in the database.

Hi Sihui,

I’m pretty sure I’m already on 2.5 since I upgrade following recommendation in my first post a couple of months ago: ( HANK Flood Sensor FLD01 not recognized )

In any case I forgot how I can verify the current version I’m on. Can you help me on that please?

Through Karaf:; bundle:list | grep -i zwave
And please report your device type and id (from your xml)

You need to have one of these:
or we will have to add yours to the database.

Thx sihui,
this is what i get for the zwave version
217 │ Active │ 80 │ │ ZWave Binding

now I will see if I can find the xml-file

Ok I’m officialy lost.
Where do I find these xml-files?

Not entirely sure where to find what you need but I’l give it a try. Is this what you are looking for? It is what I find in Habmin under the node7 which is the HANk Flood sensor.:

I have been searching for xml-files and found some on the raspPI3 under/var/lib/openhab2/zwave
in that folder there are 6 xml files with names containing “node1” through “node6”.
However in PaperUi and Habmin the sensor is on node 7 (logic because it is the last one I’ve added)
If /var/lib/openhab2/zwave is the place where to find the xml-file than I can report that there is no file created for the node7 which is the sensor that is not working.

I hope this info is helpfull??


Yes. The device has not been recognized yet, you need to include it properly.
Wake it up several times (manually wake the device up by pressing the Z-button), if that does not work you may need to exclude and reinclude.

All the way at the bottom of the node is the Attributes section. That could be helpful.

The attributes section is what I posted this morning, there is nothing more

I’m willing to do that but please be informed that last time(a couple of months ago) people sugested the same actions : manually wake up the device, exclude it an include it again and wake it up manually for a couple of times.

I actually done that! I think I must have manually woken it up more than 50 times…without any result.

So in other words I don’t put my money on it…but if you think it would help this time…I will do.

I will keep you posted but give me a few days!!