Devices are not found by Echo Dot. (OpenHab Hue Emulation)

  • Platform information:
    • Hardware: Raspberry PI 3 B+
    • OS: Raspbian
    • Java Runtime Environment: Oracle JDK8
    • openHAB version: 2.5 Snapshot

I’m trying to connect Openhab2 to Alexa via Hue emulation. But Alexa doesn’t find any new devices. I read the Hue emulation documentation and configured openhab accordingly.
With Iptables I have set up a redirection from port 80 to 8080.
After I tried to connect Alexa to OpenHab the whitlist (/api/testuser/config/whitelist) also contains the echodot…
When I access the API (http://oh_ip:80/api/testuser/) I think I get correct values back.
Already tried scanning from webinterface, from the mobile app and from the Echo devices.

  "config": {
    "uuid": "7effd055-1bac-4127-a693-f6b97fd88434",
    "timeformat": "24h",
    "timezone": "+01:00",
    "UTC": "2019-02-01T23:00:27.527",
    "localtime": "2019-02-02T00:00:27.528",
    "devicename": "Philips Hue",
    "fwversion": "0x262e0500",
    "rfconnected": true,
    "zigbeechannel": 15,
    "linkbutton": false,
    "panid": 19367,
    "dhcp": true,
    "gateway": "",
    "ipaddress": "",
    "netmask": "",
    "networkopenduration": 60,
    "proxyaddress": "none",
    "proxyport": 0,
    "whitelist": {
      "42b55703-12d7-4161-858e-8f9ab238e5e6": {
        "name": "Echo",
        "createDate": "2019-02-01T21:09:11.298",
        "lastUseDate": "2019-02-01T21:09:11.464"
      "c5850219-ab58-4ecd-ab08-c11f50f33fc0": {
        "name": "Echo",
        "createDate": "2019-02-01T21:09:11.329",
        "lastUseDate": "2019-02-01T23:59:07.409"
      "testuser": {
        "name": "Formerly authorized device",
        "createDate": "2019-02-01T23:14:55.858",
        "lastUseDate": "2019-02-02T00:00:27.528"
      "testuser1": {
        "name": "Formerly authorized device",
        "createDate": "2019-02-01T23:29:50.126",
        "lastUseDate": "2019-02-01T23:30:29.465"
    "apiversion": "1.16.0",
    "bridgeid": "7EFFD0551BAC",
    "datastoreversion": "60",
    "starterkitid": "",
    "modelid": "BSB002",
    "name": "openHAB Devices",
    "swversion": "2.5.46",
    "mac": "B8:27:EB:F9:7D:79",
    "factorynew": false
  "lights": {
    "1": {
      "state": {
        "on": true,
        "reachable": true,
        "mode": "homeautomation",
        "alert": "none"
      "type": "On/Off plug-in unit",
      "modelid": "Plug 01",
      "uniqueid": "7effd055-1bac-4127-a693-f6b97fd88434-1",
      "manufacturername": "OSRAM",
      "productname": "On/Off plug",
      "swversion": "V1.04.12",
      "hascolor": false,
      "name": "Schalter",
      "config": {
        "archetype": "classicbulb",
        "function": "functional",
        "direction": "omnidirectional"
      "capabilities": {
        "certified": false,
        "streaming": {
          "renderer": false,
          "proxy": false
        "control": {}
  "groups": {
    "0": {
      "name": "All lights",
      "type": "LightGroup",
      "action": {
        "hue": 0,
        "sat": 0,
        "xy": [
        "effect": "none",
        "transitiontime": 0,
        "colormode": "ct",
        "bri": 0,
        "ct": 500,
        "on": false,
        "reachable": true,
        "mode": "homeautomation",
        "alert": "none"
      "lights": [
  "scenes": {},
  "rules": {},
  "sensors": {},
  "schedules": {},
  "resourcelinks": {}

So far, the Openhab API seems to be working fine. But the value for Gateway is the wrong one.

 "gateway": "",

The correct address is

$ route
Ziel            Router          Genmask         Flags Metric Ref    Use Iface
default         UG    303    0        0 wlan0   U     303    0        0 wlan0

Where can I enter the correct Gatway in Openhab?
Could this also be the reason why Alexa doesn’t recognize new devices?

Excuse my english, but I used a translator to translate this text from german to english. :see_no_evil:

You only have a wall plug defined. Not all echos recognise them, try with a light as well (tag your item with Lighting).

The gateway is a fixed string, I think it is not really used by Amazon. We would need to watch the network traffic to find out.

Cheers, David

1 Like

OK, now it’s working. I added the Switchable or Lightning tags to the switches and lamps via the REST API. In the service configuration I activated the Alexa Fix.
Now the lamp and the plug are discovered in Alexa.
Thanks a lot for your help.