DEVIReg Smart thermostat binding

Tags: #<Tag:0x00007f5c98be7f98> #<Tag:0x00007f5c98be7e80> #<Tag:0x00007f5c98be7db8>

@kojtp2 control_state is read-only channel, but control_mode is read-write. Set it to “OVERRIDE”. And mind the firmware bug, described in README

I’m experiencing a memory Issue, memory consumption raises within 6 hours to maximum amount (which is 1Gig) then openHAB isn’t reachable anymore. I’ve upgraded the system to OH2.5.3, but no luck, now devireg doesn’t even start. I have to investigate, will post additional information.

1 Like

Yes, please.
It’s unlikely Devireg’s problem. Works rock stable here on 2.4, Sysinfo binding reports 25% of memory in use with uptime for about one month.
By this time i found and fixed some bugs, related to link stability, but nothing critical.
However, check your cache first. It may happen that OH retains old versions there, and they are loaded simultaneously. This can cause all sorts of weird problems.

OpenHAB rookie here. I am able to search for things in Paper UI with DevReg binding but it does not find anything. For some reason the http://127.0.0.1:8080/devireg is not working for me. I read something about running in a docker and to have correct java version. Below is my java -version printout. Any advice?

openjdk version “1.8.0_232”
OpenJDK Runtime Environment (Zulu 8.42.0.21-CA-linux32) (build 1.8.0_232-b18)
OpenJDK Client VM (Zulu 8.42.0.21-CA-linux32) (build 25.232-b18, mixed mode)

@ddtrust-dev Hi! First of all, have you installed libopensdg ? You need 32-bit version since you’re running 32-bit java.

Thanks for reply. Now I get it… I’ve installed *amd64 version of libopensdg but I should have *i386 right?

I set up the RPI now also. Installed opensdg_1.0.1-1_armhf.deb + deps with apt-get and coped the binding to addons. http://openhab:8080/devireg gives me 404 even tought openhab otherwise seems to be running ok. I am probably missing some obvious step here.

@ddtrust-dev Yes, you need i386 one.
As to RPI… Anything suspicious in the log ?
There has already been report from @Udo_Hartmann about the binding stopping working on 2.5.3. I still have no time to upgrade my own system, and on development environment everything is working fine. So unfortunately i have no clue :frowning:

Hi,

Thanks for reply. If you mean the openhab 9001 log there seems not to be anything about the devireg as I understand it. I also installed now the i386 version of opensdg to my ubuntu 18.04 but the situation seems to be the same.

I’m just wondering if I miss some simple thing here, should I run the opensdg or the binder somehow or is it sufficient just to install / copy jar to right folder after which it should work?

Regarding deps for opensdg i’ve installed following to RPI:

  • sudo apt-get install libsodium23
  • sudo apt-get install libsodium-dev
  • sudo apt-get install protobuf-compiler
  • sudo apt-get install protobuf-c-compiler
  • sudo dpkg -i opensdg_1.0.1-1_armhf.deb

In fact, I got the binding working in OH2.5.3 (fresh installation, no update), But for now I’m a bit lost, as one of my thermostates lost connection to the cloud and I can’t share my home anymore.
I have to solve this problem first, maybe this lack of connection caused the “memory leak”, too.

@Udo_Hartmann Good. Perhaps wifi configuration got broken on that thermostat. You can re-setup it by powercycling and connecting via the app in “add new thermostat” mode. The thermostat offers you 30 seconds for setup after powerup regardless of whether it’s already configured or not.
@ddtrust-dev It is very strange. I have no idea… Just in case:

  1. Make sure you have a trailing “/” after “devireg”. i.e. http://your.host:8080/devireg/s
  2. Execute in the command line:
    curl -X POST http://openhab:8080/rest/devireg/receive/0
    if everything is working, the response should be:
    {“error”:{“message”:“Invalid OTP supplied”,“http-code”:400}}
    this will show whether the binding has been initialized properly or not.

In fact if there’s something crashing you should really see it on the log.

Rookie issues here. I just figured out I need to edit also the addons.cfg. Now I should just figure out what exactly write to binding = devireg to run it I guess. So how it should be? :slight_smile:

Tried a few:
2020-03-27 16:13:58.639 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-devireg-2.5.1-SNAPSHOT’

2020-03-27 16:14:19.424 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-devireg-2.5.1’

2020-03-27 16:14:58.752 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-devireg-2.5.1’

2020-03-27 16:15:00.550 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-devi’

2020-03-27 16:15:34.113 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-binding-devireg’

Perhaps binding ID. “devireg”, yes.
However on my system this line is empty and commented out. I am a GUI man and i used PaperUI to install bindings.

Sorry, i don’t really know what this is. I don’t use text configs. I don’t know what it means. I can only see that this has nothing to do with the binding itself since apparently the problem happens even before looking at the .jar.
I simply drop the .jar to /usr/share/opehnab2/addons, next to .kar files, and it’s deployed automagically.

OK strange. I tried the simple drop approach also because I thought also that should be sufficient. Thanks anyway for support.

I finally have the /devireg/ up and running. I installed clean ubuntu 18.04 to my home computer and installed with openhabian. Still do not know what is wrong with RPI installation. For some reason receiving the house fails though. This is what I get to log:
2020-03-29 19:13:42.182 [INFO ] [vireg.internal.DanfossGridConnection] - Using libopensdg 1.0.1

2020-03-29 19:13:42.471 [INFO ] [vireg.internal.DanfossGridConnection] - Successfully connected to Danfoss grid

2020-03-29 19:14:43.749 [WARN ] [vireg.internal.DanfossGridConnection] - Last user is gone, disconnecting from Danfoss grid

2020-03-29 19:14:48.240 [INFO ] [vireg.internal.DanfossGridConnection] - Successfully connected to Danfoss grid

2020-03-29 19:15:49.557 [WARN ] [vireg.internal.DanfossGridConnection] - Last user is gone, disconnecting from Danfoss grid

Hello! How exactly does it fail? What’s the error reported ? And, just in case, since the communication takes time, what is the exact sequence of your actions ?

Can I find somewhere more detailed error log than above?

Now I finally got the RPI to load the devireg but receive house fails in similar way (see below copy paste).

Sequence: open devireg page, select share house in the devireg app, write the share number code to devireg page, press RECEIVE.

Result from RPI
“Failed to connect to the sender: Connection refused by peer” text in devireg page.
openhab:9001
2020-03-30 15:16:21.010 [INFO ] [vireg.internal.DanfossGridConnection] - Using libopensdg 1.0.1

2020-03-30 15:16:21.367 [INFO ] [vireg.internal.DanfossGridConnection] - Successfully connected to Danfoss grid

2020-03-30 15:16:25.271 [WARN ] [vireg.internal.DanfossGridConnection] - Last user is gone, disconnecting from Danfoss grid

This is the error message. And it means that the phone starts to talk to you and then suddenly rejects. This is strange, nobody has experienced this before.
My first question will be: what version of the phone app are you using ?