Devolo MT 2650 does not receive setpoint

I’m using Raspi with openhab2 and ZME-UZB1.
Cyrus Sensor and Green switch are working fine.
I selected the Devolo heating control because it delivers the current temperature.
I get the temperature but the set point is never set. I read this already in chats of 2015 and hope that this is solved.
The z-wave device list lists the MT 2650! So it should work.
What is wrong? is there a wrong setup?
I see E5 error on the Devolo thermostat.
I can see the error in log file
"unsupported command 8 for command class CLIMATE_CONTROL_SCHEDULE".
This is weird. Is MT 2650 supported or not?

Should be this one:
http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/295
I have a similar device and had to set the wakeup period manually (or at least changing the default a little bit) to get it working. Recommended wakeup value is around 300 seconds.
This can be done through HABmin.

That means no connection to your controller. Too far away? Wakeup not set?
Remove the battery and reinsert after 5 sec, the error will disappear, at least for a while.

I’m pretty sure its a warning, not an error. Just ignore that …

The CLIMATE_CONTROL_SCHEDULE command class is not supported at this time.

Hi SiHui,

Thanks for your help.!!! Und alles Gute in 2017.
I was close to send the device back. :unamused:

I set the wakeup time to 300 sec now and will monitor how it works.
I reset the controller and it took my new set point. I will monitor it too.
In general I do not understand the message transfer logic.
Why do I need a wakeup time?
Does the Thermostat Controller receives my new setup value immediately or only when it wakes up?
I Googled the E5 Error of Devolo and it says, that it could not communicate when it wakes up. http://www.zwave.de/thema/z-wave-heizungs-steuerkopf-fehler-e5/
So I assume the Thermostat wakes up every 300 sec ( now) and sends a communication string. Correct?

To preserve battery life the battery operated zwave devices “sleep” most of the time.
Messages are kept in a queue (on the controller) and are sent to the controller during wakeup.

I have no idea why this special Devolo device only starts to work properly when the wakeup time is edited (because on default mine was already set to 300).
But since then its working pretty good …

Same to you :slight_smile:

Edit:

As far as I understand only when it wakes up (I never checked that because I don’t care if the temperature changes immediately or after 5 minutes)

Hi Chris, Hi sihui,

I still have problems with the Devolo Device.
I set the wakeup time to 300 sec. OK, understood. The device wakes up and send information back to the controller. But why the Controller gets the E5 error in this case? Then the Device increases the wakeup time up to 30 minutes.

There is not much documentation on Z-Wave config parameters ( or I do not know where ) so I guess that the parameter Assoziation Groups defines that.
The following example is for another Device ( Multisensor ) . Here the openHAB controller receives the update.

For the Devolo device I cannot save this setting.

I can select “openHAB Controller” or Node 1 or Node 2 and when I saved it says Stored. But when I come back the settings it is empty again.

I tested it in Paper UI. Here I need to enter manually. But same result.

Is there a problem in the Z-Wave Binding for this device?

Thanks
Jürgen

I’m not completely sure what documentation you’re after, but the definition of the groups and configuration parameters needs to come from the device documentation since every device is different. So, please refer to the device manual for what these do - don’t expect it to come from OH documentation.

In the case of the two groups you’ve shown in the images, it may be that they do the same thing, but have different names either because the person adding the data to the database wrote it this way, or because the device manual is written this way. Either way, the explanation of what this does should be in the device manual.

Does it show “Pending”? For battery devices, you need to wait for the device to wake up so that the controller can transfer the information to the device.

The Devolo device is a re-branded Danfoss LC-13 (with a slighty improved functionality as already mentioned regarding the current temperature). So the settings should be similar to the Danfoss device (I assume the Danfoss device is much more common). I am using the Danfoss device and I haven’t set the association group for “Target for Wakeup…”. Nevertheless it’s working…

Regarding E5: How long is the distance between Controller and the Devolo thermostat? As Sihui posted, E5 indicates a communication problem. I do get this when the range between the two devices is to long (or too many walls in between). I also rarely get this E5 error when the OH controller was offline for a short period of time. When I remove the battery and put it back in, it’s gone immediately.

And also regarding E5: Have I understood you right that you get this error (always) when you change the wakeup time? Or when the device wakes up? Can you really reproduce this? If so, you should provide a DEBUG log of exactly this timeframe.

Hi Chris,

Thanks for your information.
Yes the parameter list comes from the Device. Now I know. But it is not obvious for someone who does not know how Z-Wave works.
The documentation of the Devolo device is very poor. They refer to the Devolo home control system for further information. That is unfair for all other HomeControl systems which want to use this device. I will send it back and try another one.

But to the technical detail.
Yes the value I entered will be send to the device when it wakes up. But the value should be stored into the configuration. But it is not stored. When I left the configuration dialog and come back, then the field is empty.
The examples above are 1. for the Multisensor device 2. for the Devolo device.

Hi Stefan,

The LC-13 looks very similar but I hope for a better software. I ordered some device.

The distance between the controller and the device is around 5m in the same room.
And there is a powered switch as repeater nearby.
The E5 occurs always. I assume because of the missing parameter “Target for wakeup and override notifications”. But due to the fact that I do not have any good documentation from Devolo I only have to guess.

Yes, when I remove the battery I can send a set-point. But it lasts not long and the E5 comes back again.

Thanks
Jürgen

Well, this could also be a problem. Chris (the bindind developer) has mentioned anywhere, that during initialization, the device should not send data through a repeater (because it’s not working). After the device was fully initialized, the repeater can be used. But for 5m distance in the same room a repeater shouldn’t be necessary anyway…

So you should deactivate your repeater first (if possible) and include the device one more time.

I don’t think so. As already mentioned, I haven’t set this parameter with my Danfoss devices. And they are working nevertheless.

Yes, that’s right. Devolo doesn’t help with really useful documentation. But that’s ok if the customer only uses the Devolo system. They want to keep it simple.

It’s nearly the same. :wink: It is the Danfoss device, only re-branded by Devolo. And - as you said - added with one (maybe useful) feature: Report of the current temperature.

I also tested the Devolo system and the range was quite poor. I don’t know if this was related to the controller or to the thermostat. I couldn’t get a stable connection even in the same room. So maybe it’s also a range problem of your Devolo thermostat. Let’s see if it’s working better with the Danfoss device.

It’s not that you must deactivate the repeater, but the issue is that some of the initialisation commands are not routeable as they are sent as broadcasts and a repeater will not repeat broadcast messages. So, you don’t need to deactivate the repeater - just to make sure that the controller is able to directly hear messages from the device.

I have an LC13 at home that I’ve not really tested. The E5 I believe is meant to indicate that the device hasn’t communicated with the controller, but I don’t know what command it actually uses to decide this as I’ve been able to poll the device, and I’ve still seen the E5 error so there might be a specific command.

I might try and contact the supplier, but I suspect they are all made by an OEM so it might not be so simple!

Hi Chris, Hi Stefan,

I installed a Danfoss LC-13 device.
First, the documentation is much better and the inclusion was done quickly. ( Now I know how it works. :wink: )
But I get the same E5 communication error after a while. The wake up time grows to 30 minutes and it does not get the set points.

Now I removed the switch near by the Danfoss device to avoid the problem you described. Do I need a new initialization?

I still assume, that the Danfoss device does not know where to talk to and therefore it signals a communication error.
I cannot set the “Target for Wakeup and override Notifications”. This is not correct. I can set it for other devices.
And it points directly to the problem. The Danfoss device do not know where to send a message in the network.

Can we elaborate that?

May this helps:
log file shows for this node only these messages:
2017-01-08 08:23:39.926 [hingStatusInfoChangedEvent] - ‘zwave:device:40654f0b:node5’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller
2017-01-08 08:38:53.316 [hingStatusInfoChangedEvent] - ‘zwave:device:40654f0b:node5’ changed from OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller to ONLINE
2017-01-08 08:53:39.932 [hingStatusInfoChangedEvent] - ‘zwave:device:40654f0b:node5’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller
2017-01-08 09:08:56.933 [hingStatusInfoChangedEvent] - ‘zwave:device:40654f0b:node5’ changed from OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller to ONLINE
2017-01-08 09:23:39.934 [hingStatusInfoChangedEvent] - ‘zwave:device:40654f0b:node5’ changed from ONLINE to OFFLINE (COMMUNICATION_ERROR): Node is not communicating with controller

Same here, but the device works without any problems …

For me the device started working as stated in my post above:


Just set the wakeup period, wake it up several times and you should be good to go …

What do you mean? The target node is not something that is exposed in the UI for any devices - is that what you mean? The target will (or should!) always be set to the controller if you have the “Master Controller” option set.

Do you receive any wakeup notifications from the device in the debug log?

I just checked the code - while there is an option to set the wakeup node, it’s not used and the node will always be set to the controller when you change the interval, or automatically during initialisation.

Hi Chris,
with the LC-13 I now have a real good documentation.
I send you a scan of the docu.
Here we can see the technical requirements:
“After a successful inclusion the controller must send a WAKE_UP_INTERVAL_SET command to the device in order to where and when the device should communicate wireless. If not, the thermostat cannot perform wake ups and the alarm and antenna symbol will flash.” This is the case for both my thermostats ( Devolo MT 2650 and Danfoss LC13).
Under troubleshooting we can find
"E5 : The thermostat is not receiving the expected replies from the control system. Check that you have a Z-Wave certified controller running … (see technical requirements )

This is exactly the current behavior. And the device will not send the notifications to the default controller. It must be set.

I never saw a message to the device. Can you please check the code. Can you tell me how to support. ( Where can I see more communication details?)

LC-13 docu.pdf (710.3 KB)

The controller already sets up the wakeup interval and the target during intialisation. It works for every device I have and I’d be very surprised if it doesn’t work here. Again, you can do this manually if you want - just set the wakeup time.

Can you post the XML for this device please?

One other point - on my LC13 the wakeup was set ok as well during initialisation, but let’s take a look at your XML if you can post it…

OK, Thanks.
I try to send a wakeup notification message again
maybe that was the missing message.