Dimmable Lights - Dim level not saved - Goes to 0 and 100% when switch off and on

Running Openhabian 2.3 Snapshot #1205, dimmer bulbs GoControl/Linear LB60Z-1. Config parameters have been set for the bulb to restore the previous dim level when turned ON. The bulbs are returning to the previous dim level value when turned on, but OpenHAB is showing a status of 100% brightness. I set the polling rate for the bulb down from 30mins to 15 secs and the dim level status in OpenHAB updates to the correct value of dimness when polled so I know this device responds with status. Is this a known issue?

Any guidance @chris ?

Not really - have you looked at the logfiles to see what is happening?

Hallo, I think I have the same issue described here.
I am developing a new binding on 2.3.0-SNAPSHOT.
My dimmable light remembers the previous dimmer value.
However as soon as from PaperUI I send an ON command to the light, OH2 sets immediately its brightness to 100%.
My log:

0.973 [INFO ] [arthome.event.ItemCommandEvent:51 ] - Item 'mybinding_xyz_brightness' received command ON
[… my binding receives handleCommand and stops on a breakpoint … ]
0.993 [INFO ] [smarthome.event.ItemStateEvent:51 ] - mybinding_xyz_brightness updated to ON
0.999 [INFO ] [s.event.ItemStateChangedEvent :51 ] - mybinding_xyz_brightness changed from 0 to 100

as you can see by binding handleCommand has just entered and yet OH2 assign bightness 100% to the channel just after receiving command ‘ON’.
This is wrong because the binding should have the right to set the brightness to current level of the device.
Any ideas?


Sounds like a use case for autoupdate=“false” ?

I could I check that? my items are generated automatically by PaperUI, they are not configured in the .items file.

Still seeing this issue on any dimmable light item. I have set the config in PaperUI to store the dim level value, but the slider still goes to 0 when the switch is turned off and to 100 when turned on. Need some guidance.


23:15:27.013 INFO [safeCall-8] zwave_device_ddd34beb_node2_switch_dimmer updated to OFF
23:15:27.020 INFO [safeCall-7] zwave_device_ddd34beb_node2_switch_dimmer changed from 53 to 0
23:15:49.614 INFO [safeCall-7] Item ‘zwave_device_ddd34beb_node2_switch_dimmer’ received command ON
23:15:49.619 INFO [safeCall-8] zwave_device_ddd34beb_node2_switch_dimmer updated to ON
23:15:49.621 INFO [safeCall-7] zwave_device_ddd34beb_node2_switch_dimmer changed from 0 to 100

@massi , Did you find a fix for this?

Have you seen issues with Dim levels for dimmable lights not being saved when the light is switch off and on?

Did you find a fix?

No - I’ve not had any problem with this. If it’s not saving, then possibly the switch doesn’t support this feature, or possibly you haven’t enabled the restore function in the channel configuration.

Can you give little more details? How can one set the channel config to make it remember the last value before switch off?

  • @chris
    I’m seeing this behavior on both Linear LB60Z-1 bulb and GE 14295 In wall switch, both dimmable light devices. Store Last Value is enabled on the dimmer channels for all. I can dim the light with the slider in PaperUI/Control, but turning off or on the switch takes the dim level to 0 or 100 even though the bulb is still illuminating at the original set dim level. Either OpenHAB is not requesting a dim level status when turned on and or the last dim level doesn’t persist. I see this behavior in all of the OpenHAB instances I’ve loaded and the Eclipse Smarthome instance I’ve implemented.

There is a channel configuration called “Restore Last Dimming level on ON”. This changes what the binding will send when you turn the light on - it will either send 255, or 254. 255 tells the light to turn on fully, while 254 tells it to restore the last value. If the bulb doesn’t actually support this, then there’s nothing more that the binding can do.

The Linear Bulbs and the GE switch turn on to the saved dim level either by default or because it supports 254. When turned on, the bulb may be on 50% (saved dim level) but OpenHAB shows a state of 100%. The devices are functioning correctly, OpenHAB is not showing the correct state of dim level. At some point OH2 polls the device, I think every 30 mins by default, it picks up on the correct dim level and shows it.

I’ve created a PR that will hopefully solve this issue. I’ve added a delayed poll after a command is sent to a device. By default, the device state will be polled 1.5 seconds after a command is sent to the device - this time allows the device to complete its update and achieve a steady state.

The delay can be set between 100ms and 15 seconds, or the post command poll can be disabled by setting the value to 0.

I looked at a couple of other options to solve this, but other options potentially added a lot of complexity, or could clog the network if a lot of devices were adjusted at the same time.

I’ll do an update to the development binding later tonight - let me know if it solves the issue.