Dimmer Value - Set Acceptable Values It Can Be

I have an dimmer item that can only be 33, 66 or 99 (it’s a Fan)

Is there a way to have it jump up/down by those values in the SiteMap? If I try to make it jump from 33 to 66, it only goes by 1 number increments and then jumps back to 33.


Dimmer		BondRyanFan_Speed				"Ryan Fan Speed [%.1f %%]"												(gBondFanSpeed)		{ channel="bondhome:bondFan:20e865fb13:0000003b:ceilingFanChannels#fanSpeed" }

I tried setpoint below, but it doesn’t work as you would expect it.


Setpoint	item=BondRyanFan_Speed				icon="slider"			label="Ryan Fan Speed - Bond"						minValue=0 maxValue=100 step=33	

Best, Jay

I use a selection with mapped values for high/medium/low/off. You could also do that with a switch if you want a one-click solution.

This should work

Setpoint item=xxx       minValue=0 maxValue=99 step=33 icon="xxx"

This didn’t work, it was similar to what I posted on the sitemap above with max = 100, change it to 99 but it didn’t help.

minValue=0 maxValue=99 step=33

Best, Jay

Does it work when you set the minvalue to 33?
Then you need an additional switch to turn it off.

Ok - we are making progress! It works but I have to press the up/down many times to get it to move and save that change.

I’m guessing this has to do with the value reflecting what the actual item setting is and it’s taking a while for it to change, hence its bouncing back.

Isn’t there a setting on the item level that stops this from happening?

Best, Jay

Are you using this in one of your own developed bindings? Or in one of the official ones (if so which one)? Either way, such a setting is done in the state description part of the respective channel in the things.xml file.

Attached binding, remove .txt from it.
org.openhab.binding.bondhome-3.3.0-SNAPSHOT.jar.txt (57.2 KB)

Would putting this switch on the speed item work based on what I’m experiencing?

[ignoreStateUpdates= “true”]

Best, Jay

@jwiseman it is probably best if the author of the bondhome binding ( @ccutrer ) would answer your question.

This is the syntax that works now with the SiteMap.

{ channel="bondhome:bondFan:20e865fb13:0000003b:ceilingFanChannels#fanSpeed", autoupdate="false" [ignoreStateUpdates= "true"] }

Best, Jay

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.