Disable auto discovery of things in PaperUI

Hello, is there a way to disable the auto discorvery in PaperUI for all bindings at once?
It should just put things in the inbox if i manually trigger the discovery function of a binding.

I tried this in the karaf console without success:

smarthome:discovery disableBackgroundDiscovery *

Thanks a lot

No one a clue?

I also asked this once, because in some binding readme’s, the author wrote:

The binding can auto-discover the Onkyo AVRs present on your local network. The auto-discovery is enabled by default. To disable it, you can create a file in the services directory called onkyo.cfg with the following content:
This configuration parameter only controls the Onkyo AVR auto-discovery process, not the openHAB auto-discovery. Moreover, if the openHAB auto-discovery is disabled, the Onkyo AVR auto-discovery is disabled too.

But seems not to work for me either…

Does anyone found a solution? I would also really like to disable the auto discovery for some bindings, like the hue binding. I’ve added my things manually and am getting now log entries like:

Discovery Result with UID ‘hue:bridge:########’ has been added.
Discovery Result with UID ‘hue:bridge:########’ has been removed.


Added new thing ‘hue:bridge:########’ to inbox.

every couple of minutes.

@Riza_Aslan did you figure this out? I am having the same issue.

Hi there,

I am interested in this topic too. According to the documentation it is possible to disable background discovery for bindings by setting discovery.hue:background=false in your runtime.cfg. I have not tested it yet.

I have tested and it’s still tries to discover. I am not sure how to debug. But all docs said I configured correctly.

@cweitkamp let me know if you try and it works!

@Thedannymullen I tried it too. Unfortunately it did not work.

There is a more invasive way: You can try to disable the UPnP discovery completely by setting discovery.upnp:background to false. Be careful with it.

Thanks glad to know it wasn’t just me! It isn’t more of an annoyance in the logs. I will probably not worry about it at the present moment. I will keep it on the list though for future.

i found a work around. I renamed the channels in my hue items file. Once the channels match what paper ui thinks they should be called then it quits showing them in the inbox.

named like this: hue:0220:1:8:xxxxxx
where xxx is brightness, color, etc.

You may have to change your thing file also. But This got rid of the auto discovery.

1 Like

Hi @Thedannymullen, do you mean like this:

Bridge hue:bridge:1 [ ........ ]
    // Livingroom chair standing light
    0220 bulb_chair [ lightId="1" ]


// Livingroom chair light
Switch SW_ChairLight "Staandelamp stoel" (gLivingroom) {channel="hue:0220:1:1:brightness"}
Dimmer DM_ChairLight "Staandelamp stoel dimmer" (gLivingroom) {channel="hue:0220:1:1:brightness"}
Dimmer CT_ChairLight "Staandelamp stoel kleurtint" (gLivingroom) {channel="hue:0220:1:1:color_temperature"}

The thingID (bulb_chair) can be ignored?
Currently I have entries like this:

Switch SW_ChairLight "Staandelamp stoel" (gLivingroom) {channel="hue:0220:1:bulb_chair:brightness"}

You have to look at your paper UI. Under the configuration --> things. Click on the Hue gateway get the serial number.

Put the serial number of the hue bridge in your thing files: Bridge hue:bridge:00178827d80b

After this use that in your channel configs: channel=“hue:0220:00178827d80b:1:brightness”

Your light id declarations are fine. This is how I got the inbox to quit filling. But you have to use the serial number of the bridge in the things file.

Thanks. I will add the serial number in the declarations.
Hope to get rid of these spurious log messages…:grin:

1 Like