Disable internal proxy

I was using v1.5 for a long time. Today I upgraded to v1.8.3 and I have problems with WebViews ( Probably I had this problem before so I never upgraded to 1.6)

I access bunch of local websites localy and display them in webviews (utorrent, couchpotato, logitech media server etc.)

Everyhing works fine on PC with Classic UI ( URLs are like in the sitemaps ) but in GreenT (yea I still love it) they are rewritten like:

https://192.168.15.15:8443/proxy?sitemap=my.sitemap&widgetId=01060100

Also on mobile Habdroid just displays white pages. Is there a setting to disable this proxy engine? I really do not need it.