Discourse setup - OH Forum missing icon

@Kai This is not so important but annoying.
The tab icon of the Community forum is not displaying OH logo anymore

What do you mean??

I don’t know what is meant with “discourse setup”, however on my (chrome) browser the tab icon shows up. @Pedro_Liberal , IMHO your screenshot is from a device with a small screen, which doesn’t show the tabs at all.

For me it shows as well:

I see these entries in the page’s header


<link rel="icon" type="image/png" href="https://community-openhab-org.s3.dualstack.eu-central-1.amazonaws.com/optimized/2X/9/9f4fccdc9c347b1f9cfbd18748a5d0f7d5065d8e_2_32x32.png">
<link rel="apple-touch-icon" type="image/png" href="https://community-openhab-org.s3.dualstack.eu-central-1.amazonaws.com/optimized/2X/5/59a91d5aac9b5fafe843efc04e2edda03f3c2ec6_2_180x180.png">

Accessing them I get 403 server error.
Same error message is being displayed in chrome’s webconsole for these icons/pngs.

I wouldn’t call the screen of an iPhone XR small resolution… sure it’s not full hd, but it’s not 720 either.
I tried again and I still don’t see an issue. Might it be geographical??

That’s because your screenshot is not showing the top of a browser tab. The OP is talking about the icon on the browser tab, not the header of the web page itself.

In DevTools I see this error:

On FireFox and Safari I do not see the icon too

Humm I see.

So, you are not seeing the tab-icon too?

correct.

I think it is broken for everyone however browsers cache favicons. I also saw these 403 errors on page reloads but still a correct favicon was showing. Even after clearing the Chrome browser cache it still kept showing the favicon. However I could reproduce it by renaming the cache (~/.config/google-chrome/Default/Favicons) and restarting Chrome. Then the favicon was broken for me as well. :frowning:

1 Like

I’ve checked the S3 bucket and the referenced images indeed do not exist there. They are supposed to be created automatically by Discourse (they are downscaled images of the original upload).
Unfortunately, I have no clue why they weren’t generated (or disappeared?) and how such optimized image generation could be manually triggered. I also tried to upload the icon again, but it didn’t have any effect…

Have you tried to upload a different one ?
I read that in case the checksum for a new upload is the same as for the previous upload the upload will not be done ( Favicon is failing to load for logged-in users - #4 by codinghorror - support - Discourse Meta )

Good hint - I just changed the icon slightly, uploaded it again and - it still does not work. :frowning:

1 Like

I think that is not corect. I just used browser refresh ( shift reload ) and now I see the favicon in the firefox browser tab. That was not the case before.
Screenshot from 2022-07-16 13-08-51

Chrome also shows the favicon again.

1 Like

Indeed, now I see it as well - great, then I guess we can consider this solved!

1 Like