Distributing bindings through the IoT Marketplace

You need to install the Eclipse IoT Market binding under Misc (in PaperUI). This will add the bindings listed in the Eclipse Marketplace to the list of other bindings (you will need to refresh the page to see the marketplace bindings). If that is what you mean.

There is no relation between a binding openHAB and the same binding in the Eclipse Marketplace. openHAB just sees them as 2 different bindings. Although you should not install them both, since they do use the same name space. So there is no priority.

Bindings in the marketplace are either bindings not (yet) available in the core or are beta releases of existing bindings with bug fixes/new features that are not yet available in the core (not merged or only available in the latest snapshot version).

Installing a new version from the Eclipse Marketplace can be done by uninstalling the current one and then installing the newer version I think. There is no automatic update of new versions. This is a nuance especially when upgrading openHAB to a newer version it will uninstall market place bindings (See comment above in this thread)

That is normal after upgrading. Every time cache and tmp folders get deleted (for example during an update) you need to reinstall your market place bindings.

Just a wild guess: The Eclipse Foundation servers were under heavy load the last two days due to the Photon release and we had all kinds of issues with builds etc. So maybe the Marketplace had some hick-ups through this as well…

Hi - i am on OH 2.2 and cant see the IoT Marketplace in MISC !?
how can i install this - need it for my Xiaomi Roborock Vacuum Binding

EDIT:
OK got it - its in the Eclipse Marketplace -> with Config -> Maturity Level: Alpha

This does not work for me, strange? I have:

addons.cfg

binding = mqtt1,...,binding-3741544
misc = restdocs,...,market

Any hints?

I’ve tried the following:

binding = market:3741544 -> NOPE
binding = binding-3741544 -> NOPE
binding = 3741544 -> NOPE

Still nothing.

It needs to be in the MISC part.

None of this is working either:

addons.cfg

binding = market:3741544 -> NOPE
binding = binding-3741544 -> NOPE
binding = 3741544 -> NOPE
binding = market:binding-3741544 -> NOPE
misc = market:3741544 -> NOPE
misc = binding-3741544 -> NOPE
misc = 3741544 -> NOPE
misc = market:binding-3741544 -> NOPE

I do the install with PaperUI, so can’t help any further.
Did you make sure you are using the correct numbers? Check via PaperUI …

Yes the number is definitely correct, copy-pasted from PaperUI.

Okay, that should be the Sony binding.

For the MISC part: my answer was not correct. If you need to install the market place addons it would go into the MISC part, a market place binding should go into the BINDING section …

That’s exactly what I am trying. The Market add-on is installed.

What’s the process for getting Marketplace bindings approved by moderators? I submitted my first binding using this guide a couple days ago, but it still says pending moderation. Do I need to ping a moderator to review? What criteria is used to determine if a submission gets approved?

btw my binding is submitted here: https://marketplace.eclipse.org/content/konnected-binding

Hey Nate! Thanks for the submission, please just be patient - the approval is done by the folks at the Eclipse Foundation and they do not seem to do it daily. Shouldn’t take more than a week, though, from my experience.

1 Like

Hi Tonny,

did your WARN message left after certain period of time? I have currently the same WARN message in my log

2018-09-23 17:50:24.258 [WARN ] [arketplace.internal.MarketplaceProxy] - Failed downloading Marketplace entries:  : Received fatal alert: handshake_failure
2018-09-23 17:50:24.261 [WARN ] [arketplace.internal.MarketplaceProxy] - Retrying again in a minute

Thanks

Happening to me also; even updated the Java Security files for US thinking it has to do with 256 encryption issue but that didn’t work either.

Best, Jay

1 Like

thanks for reporting this - i tried as well to replace the java security files, as some in this threat seemed to have success with this method.

Unfortunately not me - we obviously need to be patient.

Hi Martin.
Yeah, my warnings are gone. They disappeared after my re-install of OH2.

worked for me, thank you!