DMX Chaser Crashing out?


(Scott Mc) #1

Hi All,

Im using a dmx chaser with the following configuration;

.things
chaser kitchen_rgb_chaser [dmxid=“68,69,70,71,72,73,74,75,76,80,81,82,83,84,85,86,87,88”, steps=“2000:255,0,0,128,128,0,0,255,0,0,128,128,0,0,255,128,0,128:0|2000:128,128,0,0,255,0,0,128,128,0,0,255,128,0,128,255,0,0:0|2000:0,255,0,0,128,128,0,0,255,128,0,128,255,0,0,128,128,0:0|2000:0,128,128,0,0,255,128,0,128,255,0,0,128,128,0,0,255,0:0|2000:0,0,255,128,0,128,255,0,0,128,128,0,0,255,0,0,128,128:0|2000:128,0,128,255,0,0,128,128,0,0,255,0,0,128,128,0,0,255:0]”, resumeafter=true]

.items
Switch Kitchen_RGB_Chaser “Kitchen RGB Chase” { channel=“dmx:chaser:MainDmxBridge:kitchen_rgb_chaser:switch” }

When the chaser is switched on, I get one run through of the chaser - with the last step holding instead of looping back to the start.
My switch value is updated from on to off and the log file fills with “Second Suspend for xx previous will be lost messages”

From this point on I have lost all control of all dmx channels within the chaser and require a restart of oh to restore operation.

What Id like is the chaser to run and repeat until stopped - then resume previous values - can somebody point me in the direction where ive gone wrong with this setup?

Thanks!
Scott


(Udo Hartmann) #2

I don’t use dmx, but I guess you’ll have to use quotes:

... , resumeafter=true]

vs.

... , resumeafter="true"]

Please consider to use code fences, as otherwise discourse will change some chars

" vs. “ and ”, ' vs. ‘ and ’

.things

chaser kitchen_rgb_chaser [dmxid="68,69,70,71,72,73,74,75,76,80,81,82,83,84,85,86,87,88",
                           steps="2000:255,0,0,128,128,0,0,255,0,0,128,128,0,0,255,128,0,128:0|2000:128,128,0,0,255,0,0,128,128,0,0,255,128,0,128,255,0,0:0|2000:0,255,0,0,128,128,0,0,255,128,0,128,255,0,0,128,128,0:0|2000:0,128,128,0,0,255,128,0,128,255,0,0,128,128,0,0,255,0:0|2000:0,0,255,128,0,128,255,0,0,128,128,0,0,255,0,0,128,128:0|2000:128,0,128,255,0,0,128,128,0,0,255,0,0,128,128,0,0,255:0]", 
                           resumeafter="true"]

(Stuart Hanlon) #3

Hi

I was going to post the same question until I found this. Thanks.

One small observation…

I strictly use the PaperUI as I’m uncomfortable with text / code editing.

I originally set the resume after finish to on / true, but had the same experience where the chase runs and stops at the end. (Fades to black if I set a hold time, or holds if I set the last hold time to -1)

Oddly, if I switch OFF the resume after finish the chase will loop continually.

It’s a great binding, all I have to do now is program a LOT of chase steps :tired_face: