Do not understand how to set Zwave binding to Inclusion Mode?

  • Hardware RAZ Pi4
  • OS: openHAB Ver: 2.5.9 Release Build
  • openHAB version: openHAB 2.5.9 Release Build

I have three Zwave sensors that I struggle to get included.
The edit and documentation for the zwave binding directs me to set the binding in inclusion mode, but it is not clear to me precisely how this is done. I set controller to Master, timeout to 30, sis node +1 High Power Inclusion, and do not use security. The action switches are off.

Trying to include an Ecolink door / window open indicator model DWZWAVE2.5-ECO, Thing type eco_dwzwave25_00_000.

Cycled Raz power and toggled some action switches.

Suggestions?

Thanks
Jim

Hi!

Just go to the things page and click the plus icon to add new things, then select the zwave binding.
The binding now puts the coordinator in inclusion mode and your things should show up when you wake them up.

The window said that it was searching but couldn’t find anything. I set the door indication as directed in the literature and it acted correctly but failed to join the network.

I thought I could capture the log of this transaction but could not figure out how to get to the log. I followed the directions in the documentation:

Viewing Log Messages

You can learn more about openHAB and how it works by looking at your log files. These will tell you everything you might need to know.

To access the current log of openHAB, execute the following command in one session or have both files separated in sessions side by side:

tail -f /var/log/openhab/openhab.log -f /var/log/openhab/events.log

and used putty to connect but don’t know where this mesage goes.

Would the log be helpful? Is it easy for a beginner to access?

Thanks
Jim

Has the controller been discovered already? Just asking, that is step one

Zwave devices will not be found if they have been included into another network.
I have a lot of devices that come out of a kit already connected to a controller ( which i dont use)
You may need to exclude the devices first (any controller can do this) this is what I do for devices with buttons/leds other devices will be different no doubt

  1. turn on exclusion mode on controller

  2. press button on device ( wait for flashing confirmation if the device has leds )

  3. scan for new devices in openhab ( inclusion mode)

  4. press button on device ( wait for flashing confirmation if the device has leds )

  5. monitor logs to see what is going on

if you are running openhabian, there is an awesome log viewer, no console needed.

EDIT: your device has no buttons, you will have to pull the battery for 10 seconds to put it in inclusion/exclusion mode, but you do have a nice blue LED to tell you what is going on

I have an active ‘things’ Z-Wave Serial Controller that is ONLINE
When I click on that ‘thing’ toward the bottom of the screen is
Z-Wave
and under that is Exclude Devices
Clicking on Exclude Devices pops up a Exclude Devices? Cancel or OK, clicking on OK the Razberry2 LED comes on with RED, following the direction for excluding my thermostat (same as Inclusion)
Nothing happens, the log shows startframes and framesacknoledged but no ‘Inbox’ appears

I need to know if the Z-Wave controller can hear ANYTHING and if it can what is it hearing?

Hi Jim,

With some Z-Wave devices, it can be a tough job to get them finally included in your OpenHAB system. Recently I bought a Z-Wave dimmer that didn’t communicate very well.

In that case I usually include (or exclude) the device directly with the Z-Way webinterface on the controller. With a Razberry, it is not so difficult.

First: login with a ssh-terminal session on your RasberryPi

  • stop the openhab service: sudo systemctl stop openhab2.service
  • start the z-way server: sudo /etc/init.d/z-way-server start

login with your webbrowser on your Raspberry-Pi

  • /8083/expert. (username: admin)

You can efficiently manage your Z-Wave devices here, by forcing the communication between the controller and your devices. You can also update your Razberry with the latest firmware.

When finished, don’t forget to stop the Z-Way server and to (re)start the OpenHAB service again in your ssh terminal session

Kind regards,
Pieter Bruinsma

1 Like

I downloaded the image from here and created the OS boot from it, that image had no X installed so no browser.
sudo apt-get install chromium-browser unclutter lxde
(2 GB of software)
sudo apt update --fix-missing
sudo apt upgrade
sudo reboot
sudo raspi-config and set boot to be graphical
but: zwave.me install on the SD image from openhab? I install his server and spent two days tinkering with it, sent some emails with logs to find PI 4 generates a lot of noise…
The good news is my CT100 no longer is ‘Linked’ I clicked on Exclude for awhile…
I’ll shutdown openhab and try installing zwave.me stuff again, perhaps on a PI 3 it will work.

Z-Way works just fine on a Rpi4, I tested that this weekend.
I see no reason it should not work with OpenHAB installed on the same Rpi.
I did this on a plain Raspian install, I do not know how OpenHABian differ.

Btw: Read this if you want to update firmware: 2nd stick also bricked - UZB firmware 5.36 update failed. Device is bricked. Return to seller - official forum
I did brick a UZB1…

My PI 4 lives in an Argo NEO case, all aluminum bottom heat sink with a magnetic lid. My 3.5Amp PI 4 power supply looks clean on the scope, with the default SD image loaded into a PI 3B in a plastic case using a 2.5Amp PI supply the noise is at 1/3 scale at 8083/expert. Using 8083/expert I can connect to the CT100! But then I hit the wall, same with OpenHAB, great stuff but at 72 I’m running out of time to learn new tricks. I had the idea of being able to dynamically set the ‘Comfort/Swing’ temperature of the thermostat so that at night I could increase the Swing, morning and evening decrease it. With a 2° Swing the furnace runs 1 hour between 00:00 and 06:00, with a .5° Swing (default) the furnace ran 3 hours. FYI: The Z-Wave.me software installed on the PI 3 without an issue, I have no idea what happened during the PI 4 installed.

@Pjotr500
Now I understand /8083/ ! After I installed it, successfully, I was able to get to the CT100 but from what I can tell I am not able to set the ‘Swing’ from OpenHAB as that setting is not exposed.

I run openhabian but cannot find the log viewer.

Please point me in the right direction.

Jim

You can use your web browser, the same way you connect to the UI, just a different port instead of 8080 9001

depending on your network setup http://openhabiandevice:9001/ should work.

Failing that http://OPENHABIP:9001/ will get you there ( but you will need to know the IP )

Thanks All
I have had limited success in including my Ecolink door / window open indicator model DWZWAVE2.5-ECO, and my Aeotec Doorbell 6 ZW162 that was not supported in the item list.

To make the channels appear in the “Control” window, I needed to add an item to the channels declared in the things window. I stared with no entries in the control window for the ecolink to a time stamp displayed for change of state. I did this:

When I added my heavy duty water heater smart switch, openHabian identified the channels and displayed automatically.
See the difference?

loaded visual studio to learn how to configure from this tool. I have two questions:
1 I opened the Demo folder and did not see any items from my water heater switch or my Eotec or doorbell. The only config folders are demo and I though my changes are not there. I don’t understand how folders work. Do i need to enter these lines manually and store them in a config folder with a new name? Then, how can I execute this new config folder?

  1. I have this communication error in my vis studio in the “output”:
    [Error - 9:25:41 PM] Connection to server is erroring. Shutting down server.

[Error - 9:25:41 PM] Connection to server is erroring. Shutting down server.

Please help.

Thanks
Jim