Docker install stuck at "Launching the openHAB runtime..."

Hi there,

I’m using the openhab docker image with the following command:

docker run
–name openhab
-v /etc/localtime:/etc/localtime:ro
-v /etc/timezone:/etc/timezone:ro
-v /home/rancher/docker/openhab/conf:/openhab/conf
-v /home/rancher/docker/openhab/userdata:/openhab/userdata
-v /home/rancher/docker/openhab/addons:/openhab/addons
-e USER_ID=1100
-e GROUP_ID=1100
-p 8080:8080
–link homegear:homegear

It’s running on a Raspberry Pi with RancherOS.

The only thing I can imagine is that I cannot create an openhab user on rancher,
therefore I’m passing the ID of the rancher user - is this a problem?

I don’t get any meaningful error messages.

Thank you!

Is it actually running? My instance apart form a couple of error messages, generally has very little in the docker logs…as openhab all logs internally.

Ie have a look at your userdata/logs/openhab.log file and there may be a bunch happening there.

Hi there!

As I’m a new user and therefor can’t open a new thread, I will use this thread because I’m having the exact same problem. Please shot me a message if that’s not ok.
I’m trying to run OH2 for a good two weeks now and just can’t get it to start, same issue as in OP.
Basic setup:

  • Quite new to Unix/Linux
  • Raspberry Pi 3B+
  • Latest updates and upgrades
  • Docker works, Portainer runs (just tested)

I’m trying to get OH2 up and running for a first time as it’s shown on the docker Openhab page with
docker run --name openhab --net=host openhab/openhab:2.4.0

For the user part I created the User Openhab:
pi:x:1000:1000:,,,:/home/pi:/bin/bash openhab:x:9001:9001::/home/openhab:/sbin/nologin

And the group Openhab

I also tried the more complex way in the section “Running from command line” but with the same effect.
The volumes created when running those commonds are available, but unfortunately, openhab.log is initial.

Please help, I’m kinda frustrated.

Did you also wait a while (5-10 minutes) for everything to get started?

I also tested the container on a Raspberry Pi 3 running RancherOS some time ago (see issue 161) and it worked well except for it taking a while to load.

Also the Debian containers work better than the Alpine containers. They may be a bit bigger but don’t have performance and native library compatibility issues.


Thanks for the immediate response, maximum I waited was 8 hrs. I just kinda don’t know how long it should take. Container is running, but nothing happens after “Launching the openHAB runtime…”
Maybe I will start a basic setup of the container again and will just check after a day… Thanks.

That’s normal but you can make it show more logging in Docker by default by adding a console logger in org.ops4j.pax.logging.cfg (see server mode).

You can also check the openhab.log file in the userdata/logs what’s going on:

tail -F openhab.log

That should show some more info about what’s happening.

You should be able to connect to openHAB in your browser (http://hostname:8080) if you see the following line in the logging:

[INFO ] [.dashboard.internal.DashboardService] - Started dashboard at
1 Like

Thank you for the tips.
When checking with
docker volume ls
And going to the mount points, the directories with the files are there, but openhab.log is empty. It was kind of the first thing I checked. I will check again in the evening.

To ease my frustration, I started a unifi container yesterday. It worked flawlessly. So I think docker itself is working.
I will continue tinkering today.

1 Like

So, I finally got to continue my experiments.
As you were saying, I just had to wait. After a few minutes i could reach the landing page with the initial selection for what kind of installation I want to start with. The log still showed the “Launching the openHAB runtime…” message and I could not see any ports with docker container ls for the openhab container.
I then selected the Demo option as I read, that this is the way to got because it installs some essential stuff and delivers a good base with examples from where it’s easier to start. After some time, it finally showed the basic panel which I did not touch because I had other things to take care of. Now, one hour later my Rasperry is pingable but no other services are working, no html-pages, no SSH. I will wait another while and maybe start a new thread or see what google tells me.

1 Like

That’s some good progress! If it doesn’t work, maybe you can find the openhab.log file and see if it contains any errors?

1 Like

I posted a question in another thread: Dispatching event to subscriber '...' takes more than 5000ms As this seems to be my problem.

I’m having the same problem. Although using --net=host, I don’t see anything on :8080. This is what the log shows:

❯ docker exec -it 537655c37eaf sh
# tail -F /openhab/logs/openhab.log
2019-09-30 09:06:05.125 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2019-09-30 09:06:05.153 [INFO ] [.dashboard.internal.DashboardService] - Started Dashboard at
2019-09-30 09:06:08.381 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

The IP addresses look a bit strange. Do I need any kind of network config to make sure those are available on the host?