Docker openHAB 3.1.0 and problems scanning my home network for things

yesterday I successfully set up openHAB 3.1.0 with MariaDB in docker containers.
Unfortunately the scans only happen in the docker network 172… and not in my home network 192…

Do I need to configure my network in docker and/or openHUB? Where exactly?

Thanks a lot for helping.

Per the instructions, to use features like UPnP and other network discovery features, you must use --net=host for the openHAB container. Then in MainUI you can choose the “primary” network to be the 192 network.

Host is already selected but how and where do I have to change ?
In “Administration/Settings/System Services/Network settings” I can’t change the primary IP-Adress from to 192…

There is a toggle there. All the networks that OH can see will be listed and you select the one to use. If it’s not listing your 192 subnet then Oh doesn’t see that subnet which means that it’s not in fact using the host’s network stack which is what the --net=host command line option to Docker is supposed to do.

You’ll need to figure out why Docker isn’t working like it should with that option used for the networking.