Does anybody really know what time it is?

Platform information:

  • Hardware: rpi 3
  • OS: openhab flash image from github
  • openHAB version: openhabian-pi-raspios32-v1.6.2b.img.xz

I can’t get my new openhab3 clock set correctly.

The habpanel time widget shows the correct wall clock time.

If I open the front tail log monitor ( http://openhabiandevice.local:9001/ ) it shows 02:00 at 7:00pm.

The regional settings have a timezone set as “(GMT-6:00) US/Central”.
I’ve double checked the GPS coordinates of my location.

I assumed the NTP server was not configured so I installed it.
The settings all look correct to me but it never shows updates in the log


  • Hostname: ( The log does show network communication failures to )
  • Refresh Interval: 60
  • NTP Refresh Frequency: 60
  • Server Port 123
  • Timezone (GMT-6:00) America/Chicago

I tried with no timezone set as well. No change was noticed.
Any ideas?

Did you set the locale in openhabian-config?

I filled out everything requested using the configuration wizard at installation.
I did not edit any files on the flash card.
I have not connected directly to the RPI (by default you cannot)

The OpenHab page, settings -> Regional, shows the correct region, language, and time zone.

The log file shows:

2021-01-20 00:49:13.137 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to ‘America/Chicago’.
2021-01-20 00:49:13.173 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to ‘en_US’.
2021-01-24 01:41:22.031 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Time zone set to ‘America/Chicago’.
2021-01-24 01:41:22.118 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Location set to ‘redacted by me’.
2021-01-24 01:41:22.125 [INFO ] [.core.internal.i18n.I18nProviderImpl] - Locale set to ‘en_US’.

Will reflash to version 1.63. Hopefully that will help.

I had a similar issue with timezones, check this thread to see if related:

Time not correct in OH3 and eventlog

1 Like

That looks like the issue I’m having. Thanks! I can’t SSH to the raspberry pi yet so it will take some research before I can fix it.

Thank you sir!
You put me onto the solution

I fixed the issue on my system (openhabian-pi-raspios32-v1.6.3.img):

  • use SSH or Putty to connect to the rpi
  • Edit the /etc/timezone file. You will need to use ‘sudo’ to edit system files. In my case it was “US/Central”
  • use “sudo sync” to flush all changes to disk
  • use “sudo reboot” to restart your system