Does Openhab run on Rock Pi 4?

Thanks for the hint, I didn’t see this comment. I already tried running Openhab in 64 bit mode, but I didn’t notice that the system is any slower yet. Maybe this is a problem that only exists on the Pine64. But I can only say for sure as soon as I the Rock Pi 4 as my main Openhab controller. At the moment I only do some tests with it.

Hi. Sorry for bringing up this old thread, @matt1 , but I’ve just bought a RockPi 4a which I thought I’d move my OH over to and I thought your install script would be a good start. I get a http 404 though. Is it completely gone or do you still have it somewhere?

If your not using a PIx, then you should use Armbian which is covered in the docs here.

Yep, I actually ended up simply installing OH the “normal” way, ie using apt. I was kinda surprised to see that actually everything just worked out of the box. I tried installing OH to an arm64 server a few years back and after days of struggling I gave up and fell back to my 32 bit server…

1 Like

Yes I believe openHAB got accepted as a ‘package/appliance’ around 6 months ago, did not see anyone comment on it here, but it caused a stir over on another jealous home automation forum.

Since you have a working setup now, you may be interested that I have been updating and splitting the scripts up into smaller files. So if you want frontail installed or the samba shares to be easily setup the same as openhabian, there are separate scripts that can be used on top of a working install (after you backup first of course). They assume it is a clean fresh install and are not smart enough to handle anything other than a clean install so don’t expect the samba script to fix or change a hacked/broken attempt to already install it.

They are found here

The scripts are plain bash commands so you can use them as a guide on what commands to use if you want to do it manually or need to fault find. If you find issues then PM me as it will be a big help next time I go to use them which is why I share :slight_smile:

They are tested under Armbian on a Odroid C2, but I’m making them ready for moving my system onto an Odroid N2+ so they have nothing in them now that are board related.