Does sitemap in OH2 no longer important?

I really getting stuck with openhab designer, I can’t make it load any configuration files . even same verson demo (1.8.3) files, I don’t know why it keep saying it’s not the configuration fodler

Does OH2 can run without site map right? as I make it running without sitemap, in paperUI controls will have items show up once Things+items paired.

Will MQTT be upgrade to 2.x Binding? I guess that will lot easier to get start with.

as I able to use OH2 wihtout sitemap until I need to get work wwth MQTT, with 1.x MQTT binding, my current solution is using HABPANNEL, I create dashboard and widget, does it same as site map? any one know where is that file saved?

Yes, openHAB 2 can run without a .sitemap but in this case, you won’t be able to use the Basic UI (and/or the Classic UI).

The HABPanel layout is not the same as a sitemap.
The configuration for the HABPanel is saved within OH2 but not as a flat file that you can easily edit.
You could export it by: HABPanel -> Settings -> Edit the local panel configuration (experts only) -> Export. This will produce a .json file that you could edit and then import (for advanced use cases only).

Let’s try to help you to fix this problem. To use openHAB 2 to its full potential, you should be able to work with flat files (items, sitemaps, rules, etc) as well as 1.x Binding configuration files (all in your `/etc/openhab2/ folder structure) and the openHAB designer is a great tool that will help you to avoid syntax errors also when you define your stuff.

Post some more info about the error that you are seeing (screenshot maybe of this: “it keep saying it’s not the configuration fodler”).

You could always use a text editor (either in linux or in windows) to modify your configuration flat files to test things out, but using the designer is highly recommended! (so, let’s fix it to work)

Thank you for your promote response also your detail explanation,
as I use openhabian, I first tried on read on samba (I found a viedeo youtube shows that way should works), than I show you the snap with my step

I also tried many difference sub directory on samba all without success, eg:
\\OPENHABIANPI\openHAB-conf\sitemaps
\\OPENHABIANPI\openHAB-userdata\etc
\\OPENHABIANPI\openHAB-userdata\config

I also try download the demo sitemap file “distribution-1.8.3-demo” and unzip to C:\Temp\distribution-1.8.3-demo (as I don’t want to mess up with current operating one

than same step as starting ,open below folder to try all with same result and same warning msg.
C:\Temp\distribution-1.8.3-demo
C:\Temp\distribution-1.8.3-demo\configurations
C:\Temp\distribution-1.8.3-demo\configurations\sitemaps

Thank you dim for waste your time on helping me, Thanks.

Ok. Since you have migrated to openHAB 2 (that’s a great move by the way :wink:), you should start using the new Eclipse Smart Home (ESH) Designer (think of it like the 2.x version of the older openHAB Designer).

The error that you are getting:

"The chosen directory is not a valid openHAB configuration directory. Please choose a different one"

is usually because the designer cannot find your personal openhab.cfg and the default openhab_default.cfg files (from the OH1 world and not really needed in the OH2 world) Link1 Link2

You could continue to use OH1 Designer by placing these 2 files (empty) in your config folder (this should fix the error) but I recommend to move to the ESH Designer (it has more syntax checks and supports more stuff):

To install the new, ESH Designer see here: http://docs.openhab.org/installation/designer.html

Try the ESH Designer and let me know if you have any problems

Note: Check also @rlkoshak 's great info here:

http://docs.openhab.org/tutorials/migration.html (primary reference)

&

Migration from OH 1.x to OH 2 Tutorial (secondary)

Really thanks for your prompt reply, I have to try it later as I am going parents home for dinner, I will revert result once I am back home

1 Like

Hi I´m not sure if this is the rigth place an I already postet this in an other thread, but as it concerns the config and the access to the config folder I thought it would fit.
Hi

I run OH2 an a odroid U3. I installed it as described in the manual.
As recommended, i tried to activate samba to work on the configuration via my windows machine.

Below are my setting and

workgroup = WORKGROUP
wins support = yes

[openHAB2-userdata]
comment=openHAB2 userdata
path=/var/lib/openhab2
browseable=Yes
writeable=Yes
only guest=no
public=no
create mask=0777
directory mask=0777
available=yes

[openHAB2-conf]
comment=openHAB2 site configuration
path=/etc/openhab2
browseable=Yes
writeable=Yes
only guest=no
public=no
create mask=0777
directory mask=0777
available=yes
read only=no
force user=root

I can see the folders on my windows machine, but its not possible to mount it as drive as you can see in the atteched Dok1 file.
Dok1.pdf (126.3 KB)

I tried to connect with my android phone and it worked within a second.
I don´t see the mistake, an hope you can help me.

replied @ Samba for Openhab directory not working like it should :slight_smile: Let’s follow up in that thread

Thanks Dim, I guess I made it works on demo files, I still not able to get it read on my openhabian yet, will keep try, wanna does designer able read the database file build by paperui? As I got few item create by papery ui, should I remove that items and manually input to xxx.items file?

Dear Dim,
I have build the sitemap by notepad++ as I can’t get the designer open file from openhabian,
funny thing is on item windows, I able to show up with all my items, just configurations,
as I open demo sitemap before, it also mention can’t found demo.sitemap at first attemp.

should be any action to do with designer to open a new sitemap?

You mean to create a new .sitemap file or to edit an existing (but new) .sitemap file?
If I am not wrong, there is a problem with the designer and you can’t create a new sitemap. In this case, create the file using any other method and then open/edit it with the designer.

I do understand that unless you press Ctrl-N on desinger, it won’t create new files
my issue is designer looks still looking at demo and not reading the sitemap on openhabian(through SAMBA)
it only show up items on by openhabian and that’s all

I am not sure if I understand the problem… maybe you need to fix the file permissions of the config files in your directories on openHabian…

Is the samba share working ok (in general?)

yes It does, I able to read/write by notepad++, that how I build the sitemap last night,
I able to works on Basic UI now, I am wonder does PAPER UI able to run sitemap? as in PAPER UI controls only shows the item create by things

No, sitemaps are used by either Basic UI or Classic UI

I guess I might know why have problem, I check on logs and found this error
"15:54:08.625 [WARN ] [sitemap.internal.SitemapProviderImpl] - Filename default. sitemap does not match the name deault of the sitemap - please fix this as yo u might see unexpected behavior otherwise."

what does it mean by default.sitemap does not matech the name default? what should I do?
also

"does not match the name deault of the sitemap "

Typo in “default”?

I create the file name as default.sitemap
Than inside the file I name the site as default

Try creating a new .sitemap file (with another name… e.g. /etc/openhab2/sitemaps/myhome.sitemap)

Then, within the new myhome.sitemap file, the first line should look like:

sitemap myhome label="My Home"
{
	Frame label="Test" {
	}
}

(backup and delete afterwards the old default.sitemap and go to Paper UI -> Configuration -> Services -> Basic UI -> Configure -> set Default Sitemap to “myhome”)

Thanks Dim, Error regarding sitemap in log is gone although I still not able to load on designer through samba,
I tried to copy the config files to windows and it works.
guess problem is on SAMBA, things get me confused were I able to read/write on windows, don’t know what the problem is…

By the way, In console, I able to read log by command "log:display"
do you know how to show realtime log? I mean once there is any new log come out, will realtime pop out, don’t need to keep repeat command on log:display

Well, you are having good progress: I am sure that you will troubleshoot the Samba issue as well :slight_smile:

Try: log:tail

Or… you could use an ssh console to your openHABian host and do:

tail -f /var/log/openhab2/openhab.log -f /var/log/openhab2/events.log

I am not 100% sure about the exact file paths in openHABian…