Dome Door/Window Sensor (DMWD1)

Has anyone gotten a Dome DMWD1 sensor to work? It adds fine but my items never trigger when the door opens or closed. I’m use to door sensors being of the contact type of this gets added as a switch.

It looks like somebody may have.It is in our zwave database.

Yeah, it gets detected and there are 3 channels (binary sensor, alarm access, battery level) but items on them don’t seem to work.

This log seems relevant:

2020-05-19 12:48:46.598 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 14: Polling…
2020-05-19 12:48:46.601 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 14: Polling deferred until initialisation complete

I didn’t touch the sensor for a few days and as soon as I moved the magnet, that log showed up.

It must not be completing the init phase for some reason.

Helo Guy,

did you get sensor working in OH? I was not able to get it working

2020-06-01 17:50:15.753 [WARN ] [wave.discovery.ZWaveDiscoveryService] - NODE 2: Device discovery could not resolve to a thingType! Manufacturer data not known.

This is currently the warn from logview

Exactly what verion of openHAB?

Is there an xml file in /var/lib/openhab2/zwave for that node? If not, it has not been fully discovered by the binding. Battery powered devices need to be woken up many times until fully discovered when first added to openHAB.

Mine is detected and I’ve woken it up a ton, all the items were added for it but they are never triggered. I haven’t found a solution yet.

I’m still not familiar or not aware about right process. I just have mine stick connected and discovered and it comes with a node two that I don’t know if it’s mine door sensor or not… please find some screen shots below:

Cheking on folder I can see two files:

[17:45:32] openhabian@openhabian:/var/lib/openhab2/zwave$ ls
network_e68e2370__node_1.xml node1.xml
[18:08:45] openhabian@openhabian:/var/lib/openhab2/zwave$

Should I do anything here onto this file? Maybe copy below data inside of node1.xml?

Node 1 is the controller (Your stick).

The data you linked to is included in the binding if you are running version 2.5.0 or later.

If you click on Node 2 and then click Show Properties I suspect you will find the manufacturer, thing type & thing ID are all the invalid setting of all zeros.

Yes, it like below. How do I create or change it to link to for exampl: ?

Wake the device manually multiple times, see the manual or the database entry on how to do that.

1 Like

Dear Colleagues,

I have delete node 2 from things then disconnect the battery from sensor and it appears on inbox again. Looks that node2 is not my FIRST sensor that I have tried to add… Perhaps it’s something from USB stick? Also I have tried to wake my sensor using reed switch and the internal K1 button and it didn’t work as well. I’m pretty new on zWave and I really appreciate your support on it. Thanks again

Dear Colleagues, I was able to add it via HabAdmin, i was not aware about it. Thanks so much for your support so far. Strange is node 2 that I don’t know what does it means…First sensor was created as Node3

That is probably your first unsuccessful attempt to include that sensor and you did not wake the sensor to complete initialization. Now you are stuck with a ghost node (search the forum on how to remove that node).

1 Like